Note the ^M --- then use dos2unix from the command line on the
Linux box to fix the line endings on that file.  The ^M character is a
sure-fire sign of a Windows-saved file.

Already tried that but I still get the same error (without the ^M of course) so I think it's not the line termination.

the php binary is indeed in this location and when I run the same script
like this:
php -f test.php

it works properly. I will have to mention that the executable flag is set in
the file's permissions.

Any ideas why is this happening?

php -v gives me:
PHP 5.1.6 (cli) (built: Nov 12 2008 11:22:34)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    The above should no doubt fix it, but in the event that it does
not, check the output from the following command line commands on your
Linux box:

        which php
        whereis php

    The first will tell you which PHP CLI binary is preferred by the
current $PATH settings, while the second will tell you where in $PATH
'php' is located.

Both commands return the same path.


Reply via email to