On Sun, Jun 21, 2009 at 5:56 PM, James McLean <james.mcl...@gmail.com>wrote:

> (Resend from around 1 week ago, because of no responses)
> Hi All,
> Over the weekend I setup a test of APC intending to benchmark a Moodle
> installation with various APC settings to see how well I could get it
> to perform. I successfully installed Moodle 1.9 and 2.0 under Apache
> 2.2.3 (installed via apt on Ubuntu 9.04), and with PHP 5.2.9 compiled
> from source. I should note, that Ubuntu had an older version of PHP
> installed from apt with Suhosin hardened PHP built in. Moodle 2.0
> required at least PHP 5.2.8, so I uninstalled the original PHP module
> before compiling and installing the 5.2.9.
> No issues there; PHP worked well and performance was (mostly) acceptable.
> Progressed onto installing APC, firstly by downloading the APC 3.1.2
> source from PECL and following the usual 'phpize, configure, make,
> make install' process which worked as expected, stop and start Apache
> and APC was present in my phpinfo();. I started with the reccomended
> PHP config exept with error_display turned on and E_ALL | E_STRICT
> enabled, and also the reccomended APC config also.
> I copied the 'apc.php' from the source tree to my webroot and changed
> the password as suggested.
> The issue arose when I attempted to benchmark my Moodle install with
> 'ab' (I realise it only downloads the single page, but it's good
> enough for what I need for now though) and the result was no different
> to before I had installed APC. View the apc.php page, and the only
> page cached is apc.php itself.. Certainly not what I've witnessed in
> the past. Then what would happen was if I viewed my seperate info.php
> page containing simply the opening PHP tag and a single line with
> phpinfo(); in the file - the cache would appear to reset, and it would
> firstly not load the info.php into the cache, it would reset the
> counter on the apc.php file back to 0.
> Through all of this, there was no errors displayed on the screen and
> no errors listed in the Apache error log either. Increased the Apache
> log level up to Debug, and no related information was displayed.
> Moodle itself worked as expected with no errors, and on a seperate
> RHEL installation I have Moodle working with APC and it is caching all
> it's files as expected.
> At this point, I thought it may be an issue with the module I compiled
> myself. I backed up the module, and allowed PECL to install the
> module, it installed 3.0.19. Restarted Apache and verified the version
> was as PECL had built and installed.
> This had no effect, and yeilded the same behaviour.
> I'm stumped as to what the issue could be, however I did see this
> issue of APC not caching files on an installation of Red Hat
> Enterprise Linux in the past - however at the time we assumed it was
> an issue with the framework we were using and due to time constraints
> simply ran without APC and didn't investigate further.
> Has anyone seen this issue in the past and perhaps even rectified it?
> Any information would be appreciated.

did you take a look at the size of the cache you created ?  also, arent you
planning to cache php opcodes, so if you load up the page, index.html, i
would expect to see a bunch of php files mentioned in the apc cache..  if
apc has support for output caching, ive not yet used it so im not sure how
much i could help there (sort of sounds like youre shooting for output
caching the way you describe things above).

maybe you  could dump out your ini settings for apc and share them here?


Reply via email to