So php is loading pg. How are you calling these functions? Can you connect or does pg_connect() gives the same error?

On 20/05/2010 12:10, Giancarlo Boaron wrote:
Yes. Phpinfo() tells me it's ok:

PostgreSQL Support enabled
PostgreSQL(libpq) Version  8.4.4
Multibyte character support  disabled
SSL support  enabled
Active Persistent Links  0
Active Links  0

Directive Local Value Master Value
pgsql.allow_persistent On On
pgsql.auto_reset_persistent Off Off
pgsql.ignore_notice Off Off
pgsql.log_notice Off Off
pgsql.max_links Unlimited Unlimited
pgsql.max_persistent Unlimited Unlimited

My PHP version is 5.3.2.
My PostgreSQL version is 8.4.4 and I'm running the server under the restrict 
'postgres' user privileges since I can't run the daemon process as 'root'.

Thank you for some help.

--- Em qui, 20/5/10, Fernando<>  escreveu:

De: Fernando<>
Assunto: Re: [PHP] Some undefined function errors
Data: Quinta-feira, 20 de Maio de 2010, 12:23
   Sorry I miss read the

It does seem that php is not picking up the pg module and
cannot find
the functions.

I assume Postgresql is in fact installed at
/usr/local/pgsql.  If you
run phpinfo(); can you see that PG is installed?

On 20/05/2010 10:46, Giancarlo Boaron wrote:
I make the function call in a php file. I'm not using
stored procedures.
If I create an empty php file and put only some of
these functions,
Apache reports de 'call to undefined function XXX'.

--- Em *qui, 20/5/10, Fernando /<>/*

      De: Fernando<>
      Assunto: Re: [GENERAL] [PHP]
Some undefined function errors
      Data: Quinta-feira, 20 de Maio
de 2010, 11:25
      Are you calling store
procedures that return cursors?  I had this
      problem with cursors because
the transaction gets committed and
      the cursor closed after they
return.  Mind you I had the problem
      on .NET using npgsql, so I
might be way off.

      On 20/05/2010 10:05, Giancarlo
Boaron wrote:
      Hi all.

      Recently, I wrote an email
about the problem I was having with some Postgres functions
that when those functions were called, I received the
following error: "Call to undefined
      After some answers, I
decided to rebuild a brand new linux virtual machine with
Apache + PHP + Postgres, but I still get this annoying error
messege with some functions like pg_prepare() and
      I compiled Postgres with
--without-readline option.
      I compiled PHP with
--with-apxs2=/usr/local/apache2/bin/apxs and
      And the compilation
process has no errors.
      What am I doing wrong? Do
I have to change something in php_config.h file? If so, what
do I have to change?
      Thank you.

Reply via email to