"Conor McTernan" <[EMAIL PROTECTED]> wrote in message
> hey all,
> I've been using apache, php and mysql on win32 for a while now, and I have
> recently decided to move over to linux *yay*, so i got myself a copy of
> Suse 7.1 personal edition.
> i now have linux up and running, but for the life of me I cannot get php
> and apache to work.
> i downloaded the sources of both from their respective sites, and I have
> managed to compile apache and get it running, and I have also managed to
> compile php(i think) but i cannot get apache to parse any of my code.
> i followed the instructions on installing php as a static object, here is
> a brief outline of what i have done
> i initially install apache, and get it running, i cannot remember what i
> configured it with, but i dont think i configured it with anything
> actually. one apache was installed i managed to get the httpd up and
> running, *note* I have installed apache in /usr/local/apache, i assumed
> that this was the norm.
> i got apache running using the apachectl command, and managed to stop it
> as well.
> i now unpacked the php4.0.6 sources, these are the most recent available
> from php.net, i unpacked this into a temp dir in my root folder (i dont
> know if this is a good or a bad thing?)
> i then followed the instructions in the php install file i configure php
> with what i want, e.g. --with-mysql
> --with-apache-prefix=/usr/loocal/apache (is this correct, or should it
> point to where my apache source code is, in which case it should point to
> /root/temp/apache1.3.6/src)
> before i run the make and make install for php i then run the ./configure
> on apache again this time enabling the php4 module, i run the ./configure
> then i run the make, i now have a httpd binary in my apache1.3.6/src
> dir(once again, i'm not really sure if it was here before) so i copy this
> to the /usr/local/apache/bin dir, shutting down apache first of course.
> once this is done i compile and install php
> i now copy my php.ini-dist to my /usr/lib dir(i think) and edit my
> httpd.conf file
> i now restart apache and fire up a test php page i name my page test.php4,
> when i load it in my browser(either konqueror or netscape6) all i get is
> my source spat back out at me.
> i'm guessing that it is just a problem with my httpd.conf, but i have made
> the changes that are outlined in the install file. other than that i've no
> idea as to what the problem could be.
> any help would be much appreciated. sorry about the length of this mail.
> conor

Do you have the following in httpd.conf:

    # And for PHP 4.x, use:
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

NB .php NOT .php4

Otherwise consider have php as a DSO then you can rebuild PHP without
rebuilding Apache.


PHP General Mailing List (http://www.php.net/)
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to