Hi all,

I'm having a bit of a problem here with getting DomDocument on PHP. I've
got a Fedora 11 system and have used the package manager to install PHP
and its various modules, at no point have I compiled PHP myself (which
has never worked when I've tried it, ever, but that's another issue)

I've made sure the xml module was installed through packagekit, but i
find no listing for any php-dom type module. I checked the line that PHP
was configured and built with as shown in a phpinfo() call, and
--disable-dom is showing, however, I believe that's actually a red
herring, as a virtual machine running CentOS also has -disable-dom
showing as a config option, and yet DOM is also clearly listed as
working further down the phpinfo() page.

Is there some sort of issue with Fedora and DOM, as I read online that
it wasn't included in the default repos. What can I do to enable
domdocument that doesn't involve compiling PHP manually (like I said,
every time I try it there's a failure because of some missing symbols or
other, but this could again be a Fedora issue)

Is there maybe an RPM somewhere that anyone knows about and has used
before, or is it simply that I need to copy or make a symlink to a .so

Full specs are as follows:
Fedora 11
Apache 2.2.15
PHP 5.2.13


Reply via email to