I have php-5.3.2 and openssl version 1.0.0b-fips installed on my Redhat 6 machine. I noticed the expected results are different from the actual results when I ran these testcases in the ext/openssl/tests directory: openssl_x509_parse_basic.phpt, bug28382.phpt, bug47828.phpt.

Then I ran: openssl x509 -purpose -in ext/openssl/tests/cert.crt ,on 2 different systems - one with openssl 1.0.0b-fips installed and the other with openssl 0.9.8k installed. I compared the results and the result from the system with openssl 1.0.0b-fips installed contains more information, such as:

Time Stamp signing : No
Time Stamp signing CA : Yes

My guess is that those testcases' results that I mentioned above probably are affected by the newer version of openssl. Is it time to update those testcases' expected results for running against openssl 1.0.0b-fips? or am I missing something?

Waiki Wright

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to