shiplu and Jim, many thanks for the hints, I solved it; wasn't related to PHP, 
but I will write it down so if others search for this problem, at least they 
will have one solution that worked. 

Jim: the Apache was configured to listen on all interfaces - I had to, because 
I have multiple SSL-enabled hosts with different keys

shiplu: it was the metric! Only problem, because these are alias interfaces, a 
simple ifmetric doesn't cut it:
#~ ifmetric eth0:1 20
SIOCSIFMETRIC: operation not supported
So I had to disable the alias interfaces with ifconfig down, the re-enable 
them; after that, add the gateways like this:
#~ route add default gw <GATEWAYIP> metric 10
so now my routing table has a metric 0 gateway for eth0, and a metric 10 for 
both aliases.

Many thanks again, and have a nice weekend!


On Fri, 11 May 2012 23:54:56 -0700, Jim Lucas wrote:
> On 5/11/2012 10:57 PM, Tóth Csaba  wrote:
>> Hi Everyone,
>> I've run into a curious problem, not even really sure it's PHP, but that's 
>> where
>> I caught it, so here it is:
>> Regards,
>> Csaba
> What IP address is your Apache bound to?  You eth0 or one of the alias IPs?
> Jim

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to