When I run the code below it writes the image to the <webroot>/images
directory on a Solaris machine running iPlanet and php4.04pl1.  When I run
the exactly same code on a Solaris machine running iPlanet and php4.08 it
tries to write the file to "<root>/images/image1.png".  Why would one write
to the webroot and one write to the file system root?  Is there
configuration directive I can put in the php.ini to resolve?  What am I
missing here?  


$key = "/images/image1.png";
$value = "http://xxx.xxx.xxx.xxx?type=PNG";;
if(file_exists($key)) {
    $diff =  time() - filemtime($key);
    if($diff >= 3600) {
$im = ImageCreateFromPNG($value);
$isCreated = imagepng($im, $key, '80');

Jeb Scarbrough

Internet Security Systems, Inc.
6303 Barfield Road
Atlanta, Georgia 30328 
Phone: 404-236-3292
Fax: 404-236-2626

PHP General Mailing List (http://www.php.net/)
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to