I recently tried to recompile PHP-4.0.6 and my pdflib extension stopped
working.  I was building it in directly but the module wasn't being
listed on phpinfo() and of course the pdf functions didn't work.  So
after many attempts I decided to try another approach and build it as a
shared module.  I had a very hard time finding any documentation about
how to even compile a shared module at all but I did finally find it.  I
got it compiled but it still doesn't work.  I recieve the following
error message when I try to load it.

Warning: Invalid library (maybe not a PHP library) 'libpdf_php.so' in
/home/httpd/html/u7/lib/pdflib.inc on line 3

I tried running 'file' on the module to see if I could find any
justification for that error.  I recieved

$ file libpdf_php.so
libpdf_php.so: ELF 32-bit LSB shared object, Intel 80386, version 1
(SYSV), not stripped

I am running on Mandrake 8.1 (I tried with 8.0 as well)

I know that the module interface is working because I compiled many
other modules (same compile) and they all work.  Then I had a really
strange idea,  I went out and found an rpm for php-pdf-4.0.6 and
extracted the share module.  It worked!  So now I am really confused.  I
am up and running but at some point I will want to upgrade so I will
need find the problem.  Anyone have an idea?


Eric Thelin                                          [EMAIL PROTECTED]
           AZtechBiz.com: Where Arizona Does Tech Business

PHP General Mailing List (http://www.php.net/)
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to