I'm currently working on a proprietary application server being used within
my company. It uses a proprietary protocol over TCP/IP to interface to
remote clients and we currently use an extension I made for PHP 4.0.6.

The problems came when we upgraded to PHP 4.1.x. We could compile our module
fine, after minor source code modifications, but the resulting library would
not work. We were never able to get a shared library out of PHP's build
system that could be loaded with dl() so we created one manually with
'gcc -shared -L/usr/local/lib -rdynamic *.o -o eta.so'.

It worked in PHP 4.0.6, linking the PHP extension file with the objects from
our communications library. But when we upgraded to 4.1.x the resulting
library would be called "invalid" by PHP, and if we created the library from
the sole object created from the PHP extension the library faild complaining
from missing symbols.

We would greatly appreciate help. We've tried downgrading to 4.0.6 but the
extension (a valid one, restored from backup) will show the same behavior.
Now we're stuck with a binary-only extension in dire need of upgrading to
accomodate new features in the server. We've followed the Zend's manual
instructions at least four times to no avail, and I'm feeling very

If someone who knows what we might be doing wrong could help, we'd be very

Thanks for your time,


PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to