We have an application that used PHP's FTP function to upload files. Now it
worked until we upgraded to 4.1.2. We have now downgraded back to 4.1.1 but
still no luck, it won't work.

We have set upload_max_filesize and post_max_size as well, and that doesn't
seem to help. Here is the following code. It has not changed since it went

srand((double)microtime()*1000000);     //Create random timestamp for the
file temp file
$randval = rand();
//Creates a temp file that the file gets put in, we then read that file
$tmpfile = "/tmp/" . $file_name . $randval;
copy($file,$tmpfile);    //line 272
ftp_put($this->connection,$file_name,$tmpfile,FTP_BINARY); //line 273
return true;

This is inside a function, and $file is the handle for the uploaded file and
$file_name is the name of the uploaded file. The weird thing is that this
will work for small files (< 1MB). Anything bigger, it gives us the
following errors:

Warning: Unable to open 'none' for reading: No such file or directory in
/Ftp.inc on line 272
Warning: error opening /tmp/IP4_0EngALLMsi.exe1419195771 in /Ftp.inc on line

Any ideas? It seems as if the big files are not getting passed in?


PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to