I've installed Apache 2.0.35 with PHP 4.2.0 on both FreeBSD and Linux, and
both yield the same result.  When the test.php page is accessed it returns
"<?php phpinfo(); ?>" instead of actually processing it.

I have the lines:
LoadModule php4_module        modules/libphp4.so
AddType application/x-httpd-php .php
in my httpd.conf files, and the /server-info page displays the server as:
Server Version: Apache/2.0.35 (Unix) PHP/4.2.0
It also indicates that "sapi_apache2.c" is loaded.  I've tried making the
php files +x, and also accessing them in directories that are set as Options
ExecCGI, but nothing causes apache to actually process the php.

I have to be doing something wrong here, but for the life of me I can't
figure out what it is.  The only thing I can think of that might help is an
AddHandler line, but I don't know what I'd put there as a handler.

Any thoughts/comments/ideas would be greatly appreciated.


PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to