I have upgraded from Apache 1.3.26 to 2.0.39 with PHP 4.2.1.
I am running FreeBSD 4.6 and everything was installed from

I have a PHP script called "go" (filename is without the .php extension)
and it is located in the root of my domain name:

It's a script that my users launch with special arguments much like this:


To get this to work, I've changed AllowOverride to All
in apache2's httpd.conf and I've added this to mydomain.com

<FilesMatch "go$">
  ForceType application/x-httpd-php

This same approach has worked perfectly for me
in apache 1.3.26, and it correctly launched
script "go" when someone opened URL such
as http://www.mydomain.com/go/something/somewhere

Unfortunately, with Apache 2.0.39 only
http://www.mydomain.com/go works okay, but
http://www.mydomain.com/go/bla/bla results in a 404 error.
(it looks as if Apache treats 'go' as directory, not as
a script - despite the settings in .htaccess - and therefore
it can't find the location)

I want http://www.mydomain.com/go/bla/bla
to launch the "go" script, just as it did with Apache 1.3.26.

I have even tried using the old 1.3.26 httpd.conf with
Apache 2.0.39 (after making the minor changes to make
it compatible with apache2), but it still won't work - same
problem :((

The only other config lines that IMHO could be possibly
related with this issue are:

RewriteEngine On
RewriteCond %{HTTP:Host} ^mydomain.com
RewriteRule ^(.*)$ http://www.mydomain.com$1 [L,R]

Am I missing something here?


= Simon

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to