Andrew,

    I tried adding these lines to my php script...

    putenv("LD_LIBRARY_PATH=/home/db2inst1/sqqlib/lib");
    putenv("DB2INSTANCE=db2inst1");
    // i assume that's the right way to create those statements....

    But... I didn't have any luck with that either :/ ..same error.

    Thanks again,
            -Doug


"Andrew Hill" <[EMAIL PROTECTED]> wrote in message
044701c23f14$d1f1b650$[EMAIL PROTECTED]">news:044701c23f14$d1f1b650$[EMAIL PROTECTED]...
Doug,

Have you tried setting the variables with putenv() ?

Best regards,
Andrew Hill
Director of Technology Evangelism
OpenLink Software  http://www.openlinksw.com
Universal Data Access & Virtuoso Universal Server


-----Original Message-----
From: Doug Smith [mailto:[EMAIL PROTECTED]]
Sent: Thursday, August 08, 2002 2:28 PM
To: [EMAIL PROTECTED]
Subject: Re: [PHP] can i use --with-unixODBC instead of --with-ibm-db2?

> I just checked my config, and I *actually* have that line in
apachectl.
Try
> that, and if it fixes it, I'll correct the doc.

although my apache is built via rpm, i put the line (.
/home/db2inst1/sqllib/db2profile) in apachectl and started httpd w/
apachectl, buuuut...

unfortunately i'm still getting the

Warning: SQL error: , SQL state tO@6#A@ in SQLConnect in
/var/www/html/db2php/db2lib.php on line 8

error...

i also tried to add "export DB2INSTANCE=db2inst1" in the same script and
that didn't help either.

could the problem be that i'm starting httpd (or apachectl) as root? i
know
the ". /home/db2inst1/sqllib/db2profile" is supposed to make apachectl
inherit the db2 environment variables, but...... somehow it's not
working :/

matt, thank you again :)

        -doug


p.s. for the record__________________________
./configure
i386-redhat-linux --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin
--sbind
ir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share
--includedir=/usr/includ
e --libdir=/usr/lib --sysconfdir=/etc --with-apxs=/usr/sbin/apxs
--with-ibm-
db2








--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php





-- 
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to