In article <[EMAIL PROTECTED]>, list+php-
> Hi,
> I just noticed a little problem(?) while using databases.
> Some time ago I wrote myself a little class that made it easier to
> handly my mysql-tasks. The class connected to a database and used a
> query like "use $database" to switch to the given database.
> This worked without a problem just as in the command-line tool "mysql",
> today however I had a database called like "data-ba_se". 
> "use"ing it gave me a note "cannot use database data-ba_se" as result.
> However it worked in the command-line mysql and it works using
> mysql_select_db(). Login, Database and password were checked for typo's
> of course.
> PHP is 4.1.2, default woody-package.
> Any idea what can be the reason for this?
>      Balu

The underscore is a mysql wildcard for a single character; it may be that 
mysql is attempting to treat it as a wildcard rather than a literal in the 
circumstances in which you are using it.

David Robley
Temporary Kiwi!

Quod subigo farinam

PHP General Mailing List (
To unsubscribe, visit:

Reply via email to