You're mixing an older library with a newer php version (or
    the other way around). Please clean up your system first.

    Please ask on [EMAIL PROTECTED] next time.
    (Reply-To set).

    - Markus

On Fri, Sep 06, 2002 at 09:56:59AM +0800, Terence Lee wrote : 
> Hello
> i've uncommended the mcrypt and mhash line in c:\winnt\php.ini. then i
> try to start the apache but encounter the following error msg
> "The procedure entry point _ecalloc could not be located in the dynamic
> link library php4ts.dll"
> "Unable to load dynamic library 'c:\php\extensions\php_mcrypt.dll" - The
> specified procedure could not be found."
> "mhash: Unable to initialize module
> Module compiled with module API=20010901, debug=0, thread-safety=1
> PHP compiled with module API=20020429, debug=0, thread-safety=1
> There options need to match"
> i m sure that the "php_mcrypt.dll" is already in that location. i've
> also tried to change the "extension_dir" in c:\winnt\php.ini to
> c:\php
> c:\php\extensions\
> c:\winnt
> c:\winnt\system32
> and copied all the required dll to corresponding directories. same error
> was encountered when i start the apache. can you advice how can i solve
> it? i would like to use the mhash and mcrypt functions.
> Terence
> -- 
> PHP Development Mailing List <>
> To unsubscribe, visit:

GnuPG Key:
"In short, the window belongs to me.
 The document belongs to the web site designer."
- Poster on opera.wishlist

PHP General Mailing List (
To unsubscribe, visit:

Reply via email to