I was working on some code and couldn't get the following form to return
anything under Windows XP with Apache 1.3.26 and PHP 4.2.3.

I've just tried in a Solaris machine with same versions of Apache and
PHP and it works just fine. Same with a Linux machine running Red Hat
and same versions of Apache and PHP. Could someone else confirm this
under XP?

I have the magic_quotes set to Off, but tried with On with the same
result. In fact the settings in the Unix machines and Windows XP with
regards to Apache and PHP are as close to each other as they can be.

If it's a known bug, is there any way I can patch or update my PHP to
have it working again?

The following code will dump the contents of $_REQUEST and $_FILES. When
a file is selected under Windows XP (and the Apache server and PHP are
running in Windows XP) the information gets lost, without a trace of an
error. Works fine when the server is Solaris


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  echo '$_REQUEST = '; var_dump($_REQUEST); echo "<br>";
  echo '$_FILES = '; var_dump($_FILES); echo "<br>";

<form enctype="multipart/form-data" method="post" action="<? echo
$_SERVER['PHP_SELF']; ?>">
<input type="hidden" name="MAX_FILE_SIZE" value="<? echo 1000*1024; ?>"
<input type="file" name="test" size="40">
<input type="submit" name="submit" value="Upload Test">

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to