I really need some help here because I am going to lose my mind otherwise!!
A script that was running fine Friday has decided not to work for no
apparent reason today. The problem seems to be with a socket_create that
just stops the script, so I created a simple test script as shown below to
see what happens. When I run this is simply drops out at the socket_create,
no error message, nothing. Again this worked fine Friday and nothing has
changed on my machine. I am running 4.2.3 on Win2K... any ideas? Help!!


$zone = "";
$port = "10000";
$command = "play";


$slip_socket = socket_create (AF_INET, SOCK_STREAM, 0);

echo('here 2');

if ($slip_socket < 0) {
   echo "socket_create() failed: reason: " . socket_strerror ($slip_socket)
. "\n";
} else {
   $result = socket_connect ($slip_socket, $zone, $port);
   if ($result < 0) {
      echo "socket_connect() failed.\nReason: ($result) " .
socket_strerror($result) . "\n";

echo('Sending command: '.$command.' for '.$zone.'\n');
socket_write ($slip_socket, $command, strlen ($command));

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to