Public bug reported:

I am having trouble with SEF's. When I goto the url that has phpns
included, say

I can see my new fine. If I click on a SEF url, the link tries to go to


Of course this does not work.

If I manually change the 1 in the url to a slash (/), I can load the
article, but only if I have an .htaccess file that includes:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteCond %{SCRIPT_FILENAME} !-f
RewriteRule ^(.*)$ index.php?a=$1 [QSA]

If I remove the .htaccess file, I cannot get any article to display.

I'm not sure if there is something in phpns causing this, or some other
server problem. I'm running phpns on a red hat virtual machine.
Everything else on my server seems to be working fine.

This is driving me crazy. I've tried editing the .htaccess file. I've
tried editing shownews.php, and I can't seem to make the "1" go away. I
can't find anything in my apache config that would be causing this. Any
ideas ???

** Affects: phpns
     Importance: Undecided
         Status: New

phpns SEF url's not correctly forming
You received this bug notification because you are a member of Phpns-
team, which is subscribed to phpns.

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to