---------- Forwarded message ----------
From: depotnet at free dot fr <[EMAIL PROTECTED]>
Date: 9 May 2007 11:54:11 -0000
Subject: [PECL-BUG] Bug #8690 [Com]: Extending simple types as complex types
To: [EMAIL PROTECTED], [EMAIL PROTECTED], [EMAIL PROTECTED], [EMAIL PROTECTED]


Edit report at http://pecl.php.net/bugs/bug.php?id=8690&edit=1

 ID:               8690
 Comment by:       depotnet at free dot fr
 Reported By:      simonslaws at googlemail dot com
 Status:           Feedback
 Id:               8690
 Type:             Bug
 Package:          SCA_SDO
 Operating System: XP
 PHP Version:      5.1.4
 New Comment:

Please find above my description of the problem.

It seems that you can't have a complex type that extends a simple
type.



I tried with your new version of SDO 1.2.0, same problem.



<?php

try {

   $xmldas = SDO_DAS_XML::create("./ddex_xsd/dsr.xsd");

  print($xmldas);

} catch (SDO_Exception $e) {

   print($e->getMessage());

}

?>



but I get this execption :

Cannot add property Namespace of type commonj.sdo#String to this data

type http://ddex.net/xml/2006/dsrm/10#CommercialModelType



Official XSD file can be downloaded here :

http://ddex.net/xml/2006/dsrm/10/dsr.xsd



WFX


Previous Comments:
------------------------------------------------------------------------

[2007-04-24 18:08:58] cem at php dot net

Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


I think you're probably describing a Tuscany problem, but there's no
link in the defect and I don't see an obvious issue which corresponds.
Please either add a link, or if this is a problem with the PHP
extension, confirm that it still exists with the latest release.

------------------------------------------------------------------------

[2006-09-14 04:36:48] simonslaws at googlemail dot com

I get the same result for restriction also:



  <complexType
name="ComplexTypeSimpleContentRestrictingComplexTypeType">

    <simpleContent>

      <restriction base="tns:ComplexTypeExtendingSimpleTypeType">

        <attribute name="AddedByExtension" type="NCName" />

      </restriction>

    </simpleContent>

  </complexType>



  <element name="RootElement27">

    <complexType>

      <sequence>

        <element name="ComplexTypeSimpleContentRestrictingComplexType"
type="tns:ComplexTypeSimpleContentRestrictingComplexTypeType"/>


      </sequence>

    </complexType>

  </element>

------------------------------------------------------------------------

[2006-09-14 04:32:20] simonslaws at googlemail dot com

Description:
------------
SDO won't load my complex type that extends a simple type in order to
add an attribute

Reproduce code:
---------------
I believe this is valid schema



  <complexType name="ComplexTypeExtendingSimpleTypeType">

    <simpleContent>

      <extension base="tns:SimpleTypeWithNameType">

                <attribute name="AddedByExtension" type="string"/>

      </extension>

    </simpleContent>

  </complexType>



  <element name="RootElement25">

    <complexType>

      <sequence>

        <element name="ComplexTypeExtendingSimpeType"
type="tns:ComplexTypeExtendingSimpleTypeType"/>

      </sequence>

    </complexType>

  </element>

Expected result:
----------------
To be loaded into the SDO type model

Actual result:
--------------
Exception in PHP Interop test: Cannot add property AddedByExtension of
type commonj.sdo#String to this data type
http://www.apache.org/tuscany/interop#ComplexTypeExtendingSimpleTypeType

------------------------------------------------------------------------


--
Edit this bug report at http://pecl.php.net/bugs/bug.php?id=8690&edit=1

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"phpsoa" group.
To post to this group, send email to phpsoa@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.co.uk/group/phpsoa?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to