Edit report at http://pecl.php.net/bugs/bug.php?id=11004&edit=1

 ID:               11004
 Updated by:       [EMAIL PROTECTED]
 Reported By:      michael dot caplan at henryschein dot com
 Status:           Open
 Id:               11004
 Type:             Bug
 Package:          SCA_SDO
 Operating System: CentOS 4
 PHP Version:      5.2.1
 New Comment:

I just realised that when I said 'the second binding element (the one
in the tns3 namespace...' I meant the second _operation_ element (i.e.
the one with the soapAction). Sorry about that.


Previous Comments:
------------------------------------------------------------------------

[2007-05-17 08:32:13] mfp at php dot net

Mike, this is overkill. We think that the second binding element (the
one in the tns3 namespace, which is really the soap namespace) is
required (we see lots of examples of this for web services on
www.xmethods.net) and we are even more sure that we must have the second
binding element. 



Are you able to get any more information about why the wsdl does not
validate? I suspect that it might be to do with the xsi:type elements.
Could you try just taking out those elements? If that is the problem we
could do a quick fix where we suppress them. In fact we do not want SDO
to generate them at all, and it would be useful for us to know that they
cause validation errors for you. After a quick fix, I could raise a
defect report on the SDO code.

------------------------------------------------------------------------

[2007-05-10 15:34:11] michael dot caplan at henryschein dot com

Description:
------------
My WSDL generated does not validate (ran against the oXygen editor and
Mindreef SOAPscope).  The bindings elements appears to be adding bogus
child elements (operation contains a child of operation & binding
contains a child of binding).





The following diff fixed these issues:





Index:
Z:/michael/labnet_online/api/lib/SCA/Bindings/soap/ServiceDescriptionGenerator.php

===================================================================

---
Z:/michael/labnet_online/api/lib/SCA/Bindings/soap/ServiceDescriptionGenerator.php
      (revision
195)

+++
Z:/michael/labnet_online/api/lib/SCA/Bindings/soap/ServiceDescriptionGenerator.php
      (working
copy)

@@ -120,18 +120,10 @@

             $binding                     =
$wsdl->createDataObject('binding');

             $binding->name                 = "{$class_name}Binding";

             $binding->type                 =
"{$wsdl->targetNamespace}#{$class_name}PortType";

-            $soap_binding                 =
$xmldas->createDataObject(self::SOAP_NAMESPACE, 'tBinding');

-            $soap_binding->style         = 'document';

-            $soap_binding->transport     =
'http://schemas.xmlsoap.org/soap/http';

-            $binding->binding             = $soap_binding;

             foreach ($service_desc->operations as $op_name => $params)
{

                 $binding_operation             =
$binding->createDataObject('operation');

                 $binding_operation->name     = $op_name;

 

-                $soap_operation             =
$xmldas->createDataObject(self::SOAP_NAMESPACE, 'tOperation');

-                $soap_operation->soapAction = "";

-                $binding_operation->operation    = $soap_operation;

-

                 $bo_input                     =
$binding_operation->createDataObject('input');

                 $soap_body                     =
$xmldas->createDataObject(self::SOAP_NAMESPACE, 'tBody');

                 $bo_input->body             = $soap_body;



Expected result:
----------------
  <binding name="Labnet_API_LabnetOnline_001_ImplementationBinding"
type="tns2:Labnet_API_LabnetOnline_001_ImplementationPortType">

    <operation name="getRestorations">

      <input>

        <tns3:body xsi:type="tns3:tBody" use="literal"/>

      </input>

      <output>

        <tns3:body xsi:type="tns3:tBody" use="literal"/>

      </output>

    </operation>

  </binding>

Actual result:
--------------
<binding name="Labnet_API_LabnetOnline_001_ImplementationBinding"
type="tns2:Labnet_API_LabnetOnline_001_ImplementationPortType">

    <operation name="getRestorations">

      <input>

        <tns3:body xsi:type="tns3:tBody" use="literal"/>

      </input>

      <output>

        <tns3:body xsi:type="tns3:tBody" use="literal"/>

      </output>



      <tns3:operation xsi:type="tns3:tOperation" soapAction=""/>

    </operation>

<tns3:binding xsi:type="tns3:tBinding"
transport="http://schemas.xmlsoap.org/soap/http"; style="document"/>

  </binding>

------------------------------------------------------------------------


-- 
Edit this bug report at http://pecl.php.net/bugs/bug.php?id=11004&edit=1


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"phpsoa" group.
To post to this group, send email to phpsoa@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.co.uk/group/phpsoa?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to