So I'm forced to set XML only, right?

Marco Pivetta - Ocramius Aethril
http://twitter.com/Ocramius


2010/5/5 Murat Çorlu <muratco...@gmail.com>

>  Meta tags don't have content actually. Maybe this is about that situation.
>
> Murat Corlu
>
>
> On 05/05/2010 12:09 PM, Marco Pivetta wrote:
>
> I just noticed that the templating engine is not displaying the content of
> my <meta/> tags in this piece of code:
>
> <tal:block metal:define-macro="field">
>     <field tal:attributes="name fieldname">
>         <meta tal:repeat="meta php:metadata[fieldname]"
> tal:attributes="name repeat/meta/key" tal:content="meta"/>
>         <value tal:content="php: row[fieldname]"/>
>     </field>
> </tal:block>
>
> tal:attributes and tal:repeat are working, but tal:content is not even
> fired! I've tried with tal:content="php:var_dump(meta)", which should
> directly write to the buffer, but it still doesn't work.
> Is that an expected behaviour? Is "meta" a reserved xml tag?
> Is it related with the document type (XML+XHTML) that I've set? Do I have
> to switch to XML only?
> Thank you in advance for any suggestions :)
>
>
>
>
> Marco Pivetta - Ocramius Aethril
> http://twitter.com/Ocramius
>
>
> _______________________________________________
> PHPTAL mailing 
> listphp...@lists.motion-twin.comhttp://lists.motion-twin.com/mailman/listinfo/phptal
>
>
>
> _______________________________________________
> PHPTAL mailing list
> PHPTAL@lists.motion-twin.com
> http://lists.motion-twin.com/mailman/listinfo/phptal
>
>
_______________________________________________
PHPTAL mailing list
PHPTAL@lists.motion-twin.com
http://lists.motion-twin.com/mailman/listinfo/phptal

Reply via email to