I've just installed 1.02 version of the xmlrpc.inc and xmlrpcs.inc to my server
and immediated ran into the following error when I attempted to include
xmlrpc.inc in a script:

Fatal error: Cannot redeclare xmlrpc_decode() in xmlrpc.inc on line 1017

I then commented out all of the code in my script to make certain that I hadn't
inadvertently included it twice, leaving only a single line that included the
xmlrpc.inc and rec'd the same error.

I then changed the single line in the script that read include("xmlrpc.inc") to
include_once("xmlrpc.inc") command and received the same error.

I then renamed xmlrpc.inc to xmlrpc.php and attempted to load that in a browser
and received the same error.

I then downloaded the 1.01 version and uploaded it to my server and received the
same error (and repeated the other steps above to make /sure/ that it was an
error in xmlrpc.inc and consistently rec'd the same error but with a different
line number that the error was occuring at).

At this point, I'm hesitantly confident that there is an error in xmlrpc.inc and
am wondering if anyone else has encountered the same or has suggestions/a
solution. Note: I've also searched the source of xmlrpc.inc and can't find any
include or require statements that might explain this behaviour. 

TIA,


--
jason perkins
www.somebodydial911.com

_______________________________________________
phpxmlrpc mailing list
[EMAIL PROTECTED]
http://lists.usefulinc.com/cgi-bin/mailman/listinfo/phpxmlrpc

Reply via email to