Hi Tomas,

Thanks for the suggestions. I may try some of those options, but not until I'm back from vacation some time in July. Me and my wife fly to Budapest on Monday. After Budapest we'll see what happens ... ;-)


/Jon

On 6/17/09 10:13 PM, Tomas Hlavaty wrote:
Hi Jon,

I tried this now, removed the -O2 flag from Makefile, and recompiled
everything, but I still get the Bus error. :-(

actually, how do you link your gl ffi functions to picolisp?  If you
use the dynamic loading feature, you should remove -O2 from @lib/gcc.l
file too I think.

You could also try to rebuild picolisp (and your gl ffi module) with
-g option (debug) (both in Makefile and @lib/gcc.l).  Then crash it
and open both executable and core file in gdb to see what and where
the problem was.  I think gdb will probably complain that it could not
find your gl ffi library (if it was loaded dynamically).  Not sure how
to avoid that easily but the error/crash message could give some clue
anyway.

It probably is something else, but it is worth trying.

Or, as a workaround, you can try gtk-server http://www.gtk-server.org/
which started as gtk server but supports other libraries as well now
(e.g. OpenGL).  It became a ffi proxy server basically, very useful
for scripting languages and for environments where you don't want to
meddle with ffi (you can also mix 32bit and 64bit code -- they run in
separate processes and also run gui programs on the server without any
x windows installed).  They have some examples on the website and you
can also have a look at an experiment I did
http://logand.com/gtk/gtk-gl-teapot.l a while ago.  If you were
thinking about going this route, I would publish the new improved
version of picolisp gtk-server interface (better callback handling and
glade support) sooner.  That might not be what you want though if want
to stay "native" os x and avoid gtk.

Cheers,

Tomas

--
UNSUBSCRIBE: mailto:picol...@software-lab.de?subject=unsubscribe

Reply via email to