Hi Jon,

> Your latest fix (picoLisp.tgz + wiki.tgz) solved my local wiki uploading
> problem, at least when I use Safari. When I use Opera (10.10), however, it

Great! I put this new knowledge into a new function 'mimetype' in
"lib/http.l" for general usage.


> gets stuck when I click the "Upload directly" button. In the terminal
> window I see this:
> 
> !? (- *Cnt (setq *Get (format *Get)))
> 4 -- Number expected

Hmm, that's a tough one. This happens in 'postForm', when the
Post/Redirect/Get sequence gets messed up.

Is this reproducible? If so, I would like to know if it happens in the
JavaScript post, or a get after redirect. We could see this if you trace
'jsForm'. If the error does _not_ happen in 'jsForm', then it is the
redirect.


> Now I tried the same thing with Opera at picolisp.com: No problem.
> <http://picolisp.com/5000/-2-I.html>

Could it be that it doesn't happen when 'httpGate' is used? I tried,
however, with Opera under Linux both with and without 'httpGate' and
could not observe any error so far.

Cheers,
- Alex
-- 
UNSUBSCRIBE: mailto:picol...@software-lab.de?subject=unsubscribe

Reply via email to