Hi Thorsten,

> > I think this error occurs because the binary 'picolisp' cannot be found.
> 
> strange, I changed $PATH and emacs exec-path:

As far as the 'picolisp' executable is concerned, the $PATH doesn't
matter at all. All that counts is how it is invoked by the scripts.
About emacs exec-path, however, I can't say anything.


> and still get the same error message:
> 
> ,--------------------------------------------------------------
> | (prog (load                                                  
> | "/home/tj1/bin/picolisp/lib/swank-picolisp/swank-picolisp.l")
> | (swank-start "/tmp/slime.1757"))                             
> | Can't exec program:                                          
> | /home/tj1/bin/picolisp/pil                                   
> |                                                              
> | Process inferior-lisp exited abnormally with code 1          
> `--------------------------------------------------------------

What happens if you execute it in the shell

   $ /home/tj1/bin/picolisp/pil

I assume that this 'pil' file is

   #!/bin/sh
   exec ${0%/*}/bin/picolisp ${0%/*}/lib.l @ext.l "$@"

so you see that it will try to execute

   /home/tj1/bin/picolisp/bin/picolisp

What does the command

   $ file /home/tj1/bin/picolisp/bin/picolisp

say?


> and there is an executable 'picolisp' in "/home/tj1/bin/picolisp/bin"
> (and without slime, with inferior picolisp mode, it works)

Ah, ok, I see.

Hmm, then I'm a bit clueless ...

Cheers,
- Alex
-- 
UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to