Hi Joe

> joebo@joebo:~/tmp/picolisp$ ./pil +
> : *CPU
> -> "emu"
> : (load "misc/fibo.l")
> /usr/bin/ld: skipping incompatible
> /usr/lib/gcc/i486-linux-gnu/4.4.5/libgcc.a when searching for -lgcc
> /usr/bin/ld: skipping incompatible
> /usr/lib/gcc/i486-linux-gnu/4.4.5/libgcc.a when searching for -lgcc
> /usr/bin/ld: cannot find -lgcc
> collect2: ld returned 1 exit status

Strange. A problem of incompatible library installations?

> Linux 2.6.32-5-686-bigmem #1 SMP Wed Jan 12 04:40:25 UTC 2011 i686 GNU/Linux

Nearly the same as I have:

Linux lab 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux

> I'm running Debian 6.0

I have squeeze with some sprinkles of wheezy and sid.

> I tried some very basic picolisp operations and they worked fine.

So the problem seems mainly with the loading of dynamic libs.

> I haven't done any native work since I had been running 32bit and so I
> don't know if there's something broken on my install or if it's an issue
> with pil64emu. In any case, I wanted to share my findings.

Sure. Many thanks!

- Alex
UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to