Hello,

I tried to upgrade to Version 3.1.1, especially for the announced use of the 
cursor Arrow-Keys, but (on a pure 64-bit Slackware 14.0 with Java):

 tar -vxf picoLisp-3.1.1.tgz
 tar: This does not look like a tar archive
 tar: Skipping to next header
 gzip: stdin: decompression OK, trailing garbage ignored
 tar: Child returned status 2
 tar: Error is not recoverable: exiting now

Ark managed to extract something (albeit a warning/error message) but e.g. the 
INSTALL file was missing and the build failed:

 cd src64
 make
 make: *** No rule to make target `sysdefs.c', needed by `sysdefs'.  Stop.

I then tried to downgrade to the old 3.1.0 Version but discovered that the now 
downloadable  http://software-lab.de/picoLisp-3.1.0.tgz (same errors as 3.1.1) 
differed from a picoLisp-3.1.0.tgz (downloaded some time ago) I had on an 
external harddisk:

 cmp picoLisp-3.1.0.tgz /home/ego/EINGANG/picoLisp-3.1.0.tgz
 picoLisp-3.1.0.tgz /home/ego/EINGANG/picoLisp-3.1.0.tgz differ: byte 5, line 1
 [length is identical 819677 bytes]

In my opinion archived versions should not be changed (except by malicious 
hackers); With the 3.1.0 Version from my harddisk the build (using Java/ersatz) 
succeeded.    
 
I find PicoLisp very interesting and hope to realize some little projects with 
it.

Answart Lauermann
---

 
-- 
UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to