Hi Rob,

> I tried several, and when I finally tried version 2.2.90 for windows 64
> bit, It went past that error and went to a 'READ ERROR 09'
> Is that a 09h Attempt to DMA over 64kb boundary using the same Wiki
> reference you supplied in a previous posting?

Yes, indeed. And interesting: This seems to be the first time that error
number 09 appears.


> How can I fix it or keep moving on? Where do I look in the source to
> troubleshoot this myself? Exciting fun anyhow, so no complaints here!

The place where this happens is "pilos/x86-64/beg.l", line 26 ff

   mov $DAP, %si                 # Disk Address Packet
   mov $0x42, %ah                # Extended Read Sectors
   int $0x13                     # Drive interrupt
   jc readError

This is the standard BIOS call to read a given number of sectors from a
drive.

   
https://en.wikipedia.org/wiki/INT_13#INT_13h_AH.3D43h:_Extended_Write_Sectors_to_Drive

This above error is correct, in that indeed more than 64 KiB are being
read from the drive (the size of PilOS is 670 KiB currently).

So the BIOS which is emulated in your version of Qemu somehow cannot
handle it. Unfortunately, I don't know of any other way, except from
writing your own "BIOS".

♪♫ Alex
-- 
UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to