Thanks a lot, David!

/Jon

> On 15. Aug, 2016, at 13:57, David Bloom <ipro...@gmail.com> wrote:
> 
> Pardon the delay Jon,  I've been under extreme amounts of stress but not
> for much longer.  I'll update the docs to reflect getting a Tinycore prompt
> rather than just a REPL.
> 
> On Aug 15, 2016 6:08 AM, "Jon Kleiser" <jon.klei...@fsat.no> wrote:
> 
>> I just want to report that my use of “docker run -v” was not correct. This
>> works much better:
>> 
>> docker run -v /Users/jkleiser/script:/opt/script -it
>> progit/docker-tinycore-picolisp
>> 
>> I can then do things like (dir "/opt/script") or (in "/opt/script/foo.sh"
>> (echo)) from inside PicoLisp.
>> 
>> /Jon
>> 
>>> On 12. Aug, 2016, at 16:40, Jon Kleiser <jon.klei...@fsat.no> wrote:
>>> 
>>> Hi David,
>>> 
>>> I have now tried your container as described at
>> https://hub.docker.com/r/progit/docker-tinycore-picolisp/, and I got
>> PicoLisp version 16.5.30 running. Does your container allow me to get
>> access to the Tinycore Linux command line?
>>> 
>>> I need to load a PicoLisp file I have on my Mac. I have tried starting
>> your container like this:
>>> docker run -v /Users/jkleiser/script -it progit/docker-tinycore-picolisp
>>> but when I from inside PicoLisp do (dir "/Users/jkleiser/script”), I
>> just get NIL, so for some reason sharing the OS X file system with your
>> container doesn’t work at the moment. Maybe the container has to be set up
>> for the new ‘osxfs’ shared file system solution? I don’t know.
>>> 
>>> If I could get at the Tinycore Linux CLI, then I could maybe get my
>> PicoLisp file by use of wget or curl (if I put the file on the net first)

Reply via email to