Thanks Joe .... I was trying various "apt update /upgrade/dist-upgrade" :)
nothing worked.
Your instructions did the trick!
Very exciting indeed!!!
Regards,
Kashyap


On Wed, Feb 12, 2020 at 12:02 PM Joe Bogner <joebog...@gmail.com> wrote:

> Hi! I was also able to build and run on windows 10 under wsl
>
> I also had the LLVM error and resolved it with this:
> https://solarianprogrammer.com/2017/12/13/linux-wsl-install-clang-libcpp-compile-cpp-17-programs/
>
>
> sudo apt-get install make clang llvm lldb pkg-config
>
>
> joebo@JB0gner-T460:~/pil21/src$ make
> llvm-link: base.bc: error: Unknown attribute kind (60) (Producer:
> 'LLVM9.0.1' Reader: 'LLVM 6.0.0')
> llvm-link: error loading file 'base.bc'
> Makefile:22: recipe for target 'picolisp.bc' failed
>
> joebo@JB0gner-T460:~/pil21/src$ clang --version
> clang version 6.0.0-1ubuntu2 (tags/RELEASE_600/final)
> Target: x86_64-pc-linux-gnu
> Thread model: posix
> InstalledDir: /usr/bin
>
>
> joebo@JB0gner-T460:~/pil21/src$ sudo apt-get upgrade
> joebo@JB0gner-T460:~/pil21/src$ sudo apt-get update
>
> oebo@JB0gner-T460:~$ curl -SL
> http://releases.llvm.org/9.0.0/clang+llvm-9.0.0-x86_64-linux-gnu-ubuntu-18.04.tar.xz
> | tar -xJC .
>   % Total    % Received % Xferd  Average Speed   Time    Time     Time
>  Current
>                                  Dload  Upload   Total   Spent    Left
>  Speed
> 100  414M  100  414M    0     0  4710k      0  0:01:30  0:01:30 --:--:--
> 5233k
> joebo@JB0gner-T460:~$ mv clang+llvm-9.0.0-x86_64-linux-gnu-ubuntu-18.04
> clang_9.0.0
> joebo@JB0gner-T460:~$ sudo mv clang_9.0.0 /usr/local
> joebo@JB0gner-T460:~$ export PATH=/usr/local/clang_9.0.0/bin:$PATH
> joebo@JB0gner-T460:~$ export
> LD_LIBRARY_PATH=/usr/local/clang_9.0.0/lib:$LD_LIBRARY_PATH
>
>
> joebo@JB0gner-T460:~/pil21$ cd src
> joebo@JB0gner-T460:~/pil21/src$ make
> ...
> joebo@JB0gner-T460:~/pil21/bin$ ls
> picolisp
> joebo@JB0gner-T460:~/pil21/bin$ ./picolisp
> : (+ 1 2)
> -> 3
>
> Exciting!!
>
>
>
> On Wed, Feb 12, 2020 at 12:33 PM Alexander Burger <a...@software-lab.de>
> wrote:
>
>> Hi Kashyap,
>>
>> > "libffi-dev" instead of libffi since apt complained that it could not
>> find
>> > libffi.
>>
>> Good to know!
>>
>>
>> > llvm-link: base.bc: error: Unknown attribute kind (60) (Producer:
>> > 'LLVM9.0.1' Reader: 'LLVM 6.0.0')
>>
>> Oh! LLVM 6 is extremely old, isn't it? I have no idea how much LLVM
>> changed over
>> time.
>>
>> ☺/ A!ex
>>
>> --
>> UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe
>>
>

Reply via email to