Or, if you are in ubuntu:

sudo apt-get install libgtk2.0-dev

On 7/16/07, Ali Afshar <[EMAIL PROTECTED]> wrote:
>
> Hi,
>
> Do you have GTK dev headers? Usually libgtk-dev or libgtk-devel or
> something like that depending on the distribution. (You will also need
> the headers for Python and PyGTK)
>
> Ali
>
> On 16/07/07, [EMAIL PROTECTED] <[EMAIL PROTECTED]> wrote:
> >
> > Hi,
> >
> > I got the following error message when executing 'python setup.py
> > build':
> >
> > running build
> > running build_py
> > running build_ext
> > building 'kiwi/_kiwi' extension
> > warning: no library file corresponding to '-L/opt/gnome/lib' found
> > (skipping)
> > gcc -pthread -shared build/temp.linux-i686-2.4/kiwi/_kiwi.o -lgtk-
> > x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -
> > lpangox-1.0 -lpango-1.0 -lgmodule-2.0 -ldl -lgobject-2.0 -lglib-2.0 -o
> > build/lib.linux-i686-2.4/kiwi/_kiwi.so
> > /usr/lib/gcc-lib/i586-suse-linux/3.3.5/../../../../i586-suse-linux/bin/
> > ld: cannot find -lgtk-x11-2.0
> > collect2: ld returned 1 exit status
> > error: command 'gcc' failed with exit status 1
> >
> > In /opt/gnome/lib there is:
> > /opt/gnome/lib/libgtk-x11-2.0.la
> > /opt/gnome/lib/libgtk-x11-2.0.so -> libgtk-x11-2.0.so.0.600.4
> > /opt/gnome/lib/libgtk-x11-2.0.so.0 -> libgtk-x11-2.0.so.0.600.4
> > /opt/gnome/lib/libgtk-x11-2.0.so.0.600.4
> >
> > Do you know what the problem is?
> >
> > Thanks,
> >
> > David.
> >
> >
> > >
> >
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"PIDA" group.
 To post to this group, send email to pida@googlegroups.com
 To unsubscribe from this group, send email to [EMAIL PROTECTED]
 For more options, visit this group at 
http://groups.google.com/group/pida?hl=en-GB
-~----------~----~----~----~------~----~------~--~---

Reply via email to