Hi!

I was trying the whole day to use medit and pida.

Here are some findings (and some bugs too).

Is use pida from todays svn (revision 1253). And tried various medit
version.
First I tried medit from todays mercurial version.
The error message is the same from medit 0.9.1.
So pida cant work (and actually  crash on startup) with medit version
higher than 0.9.0.
(I tried 0.9.1 and today's devel version).
The error message:
http://pastebin.org/16121
MooBigPaned.insert_pane() takes exactly 5 arguments (4 given)
(gvim:18746): Gdk-WARNING **: GdkWindow 0x3e00063 unexpectedly
destroyed

I compiled medit with the following compiler flags:
 ./configure --enable-moo-module --enable-libmoo --enable-libmoo-
headers \
--enable-moo-module

I had success with medit 0.9.0 and pida.
I needed to install python-cairo-dev for this. (Its not required for
the newer version). It is necessary to obtain the python module "moo".
Pida complain about nonexistant moo package.
In the source:
pida/editors/mooedit/mooedit.py:28
There is a simple import moo. I think it should be a try-except
statement, whith a bit
more information where moo is coming. (I was hunting at least an hour
what is the moo module and from where can I download(didnt discover
the proper configure options at that time, so no moo existed))

The configure option:
./configure --enable-moo-module --enable-libmoo --enable-libmoo-
headers \
--enable-moo-module --with-python

A small headache:
When pida started there was no error message, but pida was not
available in the option menu
(only vim and emacs).
I needed to delete my home directory: rm -rf ~/.pida2
And pida prompted about the three possibilities (moo, emacs, vim)

Bug:
Once I choosed moo, I cant change moo to emacs or vim in the
preference.
I cant select Edit->Edit preferences->Editor
It gives this error message:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pida/services/optionsmanager/
optionsmanager.py", line 139, in on_service_combo__content_changed
    self._add_service(svc)
  File "/usr/lib/python2.5/site-packages/pida/services/optionsmanager/
optionsmanager.py", line 93, in _add_service
    self.options_book.append_page(self._create_page(svc))
  File "/usr/lib/python2.5/site-packages/pida/services/optionsmanager/
optionsmanager.py", line 130, in _create_page
    optwidget.update(value)
  File "/var/lib/python-support/python2.5/kiwi/ui/widgets/combo.py",
line 316, in update
    self.select(data)
  File "/var/lib/python-support/python2.5/kiwi/ui/widgets/combo.py",
line 353, in select
    self._helper.select(data)
  File "/var/lib/python-support/python2.5/kiwi/ui/widgets/combo.py",
line 190, in select
    self.select_item_by_data(data)
  File "/var/lib/python-support/python2.5/kiwi/ui/widgets/combo.py",
line 220, in select_item_by_data
    % (data, self._combobox.name))
KeyError: "No item correspond to data 'mooedit' in the combo None"


A small question (only medit related), when I have builded medit, and
the package contained this file:
/usr/local/lib/libmoo.so

And when I tried imported from python it complained, that it can not
find libmoo.so
Creating a symlink to /usr/lib/libmoo.so fixed this issue.
How can I check what path is wrong in python?
(I just run python and typed "import moo")
Maybe /usr/local/lib is not inside a path variable, but Im unable to
determine in which one.

And just for closing, I discovered a small bug (or feature?) in pida
with gvim:
When I paste in gvim from the menu Edit->Paste it does not paste the
clipboard but the internal vim clipboard.

In vim term there are three different command:
ESC +p   -- paste from the internal clipboard (3 keypresses)
ESC "+p  -- paste from the clipboard (ctrl-C in a normal
application(gedit, firefox)) (4 keypresses)
ESC "*p   -- paste from X11 clipboard (selection a text. Its like
paste with the middle mouse button) (4 keypresses)

So ESC "+p means pressing the esc key after the " key (on hungarian
layout: shift-2) and after the plus key(on hungarian layout: shift-3)
and after the p key. So 4 keypresses in total.

So I think an additional "Paste from clipboard" menu item would be
highly preferable. For the newbies at least.

I would really like to test any fix for the above mentioned problem
(current medit with pida).
If somebody want, I have the deb package for medit and pida too
(ubuntu 7.10).

Best regards,
 Khiraly
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"PIDA" group.
 To post to this group, send email to pida@googlegroups.com
 To unsubscribe from this group, send email to [EMAIL PROTECTED]
 For more options, visit this group at 
http://groups.google.com/group/pida?hl=en-GB
-~----------~----~----~----~------~----~------~--~---

Reply via email to