[ 
https://issues.apache.org/jira/browse/PIG-970?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Vincent BARAT updated PIG-970:
------------------------------

    Attachment: pig-hbase-0.20.0-support.patch

This small patch ports the current HBase 0.18.0 related code source to HBase 
0.20.0. This patch works for me. It applies on the trunk of PIG as of revision 
816619. Unfortunately, I was unable to make the TestHBaseStorage unit test work 
correctly, but it seems to be a problem with my environment (classpath).
Someone else will have to test it and complete the patch (it lacks the 
hbase-0.20.0 jar file). 


> Support of HBase 0.20.0
> -----------------------
>
>                 Key: PIG-970
>                 URL: https://issues.apache.org/jira/browse/PIG-970
>             Project: Pig
>          Issue Type: Improvement
>          Components: impl
>    Affects Versions: 0.3.0
>            Reporter: Vincent BARAT
>         Attachments: pig-hbase-0.20.0-support.patch
>
>
> The support of HBase is currently very limited and restricted to HBase 0.18.0.
> Because the next releases of PIG will support Hadoop 0.20.0, they should also 
> support HBase 0.20.0.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to