Hi Krister, Thanks for taking a look at this.
On Mon, 2010-09-27 at 11:03 -0700, [email protected] wrote: > On Mon, Sep 27, 2010 at 03:06:11PM +1300, Tim Foster wrote: > > http://cr.opensolaris.org/~timf/pkglint-cli-webrev > > lint/engine.py > > - line 306: Should this be os.path.abspath(os.path.normpath(cache)) > to guard against extra slashes and the like in cache? Or is that > handled somewhere else? Good suggestion, I hadn't thought of that - it does look like abspath does the right thing though, http://docs.python.org/library/os.path.html#os.path.abspath >>> os.path.abspath(".//.///foo") '/home/timf/foo' > lint/pkglint_action.py > > - line 657: The action naming convention used on this line doesn't > match the style you've used on lines 667 and 680. > > - line 762: Replace "We" with "Package" maybe? You're right, I've fixed both of these and updated the webrev. I'll putback once the gate is unlocked, unless anyone else wants a peek in the meantime. cheers, tim _______________________________________________ pkg-discuss mailing list [email protected] http://mail.opensolaris.org/mailman/listinfo/pkg-discuss
