This is an automated email from the git hooks/post-receive script.

smcv pushed a commit to branch debian/master
in repository ioquake3.

commit 87594a58b03b850569357543b3823954b4fb0e73
Author: Simon McVittie <s...@debian.org>
Date:   Wed Sep 21 10:48:47 2016 +0100

    Remove ioquake3-dbg, rely on automatic dbgsym packages instead
---
 debian/changelog |  1 +
 debian/control   | 14 +-------------
 debian/rules     |  2 +-
 3 files changed, 3 insertions(+), 14 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 263e9da..5136858 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ ioquake3 (1.36+u20160914+dfsg1-1) UNRELEASED; urgency=medium
       code copy
   * debian/watch: mangle Debian version correctly
   * Remove a leftover comment which is now misleading
+  * Remove ioquake3-dbg, rely on automatic dbgsym packages instead
 
  -- Simon McVittie <s...@debian.org>  Wed, 21 Sep 2016 10:21:52 +0100
 
diff --git a/debian/control b/debian/control
index bee30fa..e850a33 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders:
  Bruno "Fuddl" Kleinert <fu...@debian.org>,
  Simon McVittie <s...@debian.org>,
 Build-Depends:
- debhelper (>= 9),
+ debhelper (>= 9.20160114),
  dh-apparmor [linux-any],
  dpkg-dev (>= 1.16.1),
  libcurl4-gnutls-dev,
@@ -39,18 +39,6 @@ Description: Game engine for 3D first person shooter games
  This package alone isn't of any use; to get a playable game, install
  openarena or another suitable set of game data.
 
-Package: ioquake3-dbg
-Architecture: any
-Section: debug
-Priority: extra
-Depends:
- ioquake3-server (= ${binary:Version}),
- ${misc:Depends},
-Description: debug symbols for the ioquake3 game engine
- This package contains debug symbols for the ioQuake3 game engine,
- which can be used to analyze crashes in games that use Debian's shared
- ioquake engine.
-
 Package: ioquake3-server
 Architecture: any
 Depends:
diff --git a/debian/rules b/debian/rules
index f8e17ed..642bfe4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -76,7 +76,7 @@ override_dh_install-arch:
 endif
 
 override_dh_strip:
-       dh_strip --dbg-package=ioquake3-dbg
+       dh_strip --ddeb-migration='ioquake3-dbg (<< 1.36+u20160914+dfsg1-1~)'
 
 # ---------------------------------------------------------------------------
 

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-games/ioquake3.git

_______________________________________________
Pkg-games-commits mailing list
Pkg-games-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-games-commits

Reply via email to