Indeed, I ran into this too:
http://lists.alioth.debian.org/pipermail/pkg-go-maintainers/Week-of-Mon-20160620/005631.html
and https://github.com/coreos/go-systemd/issues/183 and
https://github.com/coreos/pkg/issues/73. The good news is that
upstream seem to agree this is a problem...

On 23 June 2016 at 07:34, Bill Allombert <ballo...@debian.org> wrote:
> Package: golang-github-coreos-go-systemd-dev
> Version: 9-1
> Severity: important
>
> Hello Debian Go Packaging Team,
>
> There is a circular dependency between
> golang-github-coreos-go-systemd-dev and golang-github-coreos-pkg-dev:
>
> golang-github-coreos-go-systemd-dev     :Depends: golang-github-coreos-pkg-dev
> golang-github-coreos-pkg-dev            :Depends: 
> golang-github-coreos-go-systemd-dev
>
> Circular dependencies are known to cause problems during upgrade, so we
> should try to avoid them.
>
> See threads
> http://lists.debian.org/debian-devel/2005/06/msg02111.html
> http://lists.debian.org/debian-devel/2005/11/msg01101.html
>
> Cheers,
> --
> Bill. <ballo...@debian.org>
>
> Imagine a large red swirl here.
>
> _______________________________________________
> Pkg-go-maintainers mailing list
> Pkg-go-maintainers@lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers

_______________________________________________
Pkg-go-maintainers mailing list
Pkg-go-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers

Reply via email to