Your message dated Tue, 22 Nov 2016 19:14:12 +0100
with message-id <9fc201d7-c5ce-2f7d-5b8e-20039ab5e...@tincho.org>
and subject line Re: Can't reproduce
has caused the Debian Bug report #827426,
regarding golang-golang-x-tools: stringer is broken
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
827426: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=827426
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: golang-golang-x-tools
Version: 1:0.0~git20160315.0.f42ec61-2
Severity: important

The stringer program no longer understands how to import standard Go
packages.  For example, running "stringer -type=MyType foo.go" on the following
foo.go file:
----
    package main

    import (
            "fmt"
    )

    type MyType int

    //go:generate stringer -type=MyType

    const (
            Alpha MyType = 1
            Beta MyType = 1
            Gamma MyType = 1
    )

    func main() {
            fmt.Println(Alpha)
    }
----

produces the error:
    stringer: checking package: foo.go:4:2: could not import fmt (can't find 
import: )

Running strace shows that it's looking here:
    /usr/lib/go/pkg/linux_amd64/fmt.a
But the current golang system has it here:
    /usr/lib/go-1.6/pkg/linux_amd64/fmt.a

And indeed, when I removed /usr/lib/go and symlinked it to
/usr/lib/go-1.6 instead, stringer worked correctly.  But I'm not sure
if that simple fix breaks anything else ...

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (400, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.5.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages golang-golang-x-tools depends on:
ii  golang-golang-x-tools-dev  1:0.0~git20160315.0.f42ec61-2
ii  libc6                      2.22-9

golang-golang-x-tools recommends no packages.

golang-golang-x-tools suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
On 22/11/16 19:09, Eric Cooper wrote:
> I also don't see a problem in my current installation, which is now
> go1.7.3, so feel free to close this.

So I guess we fixed it without noticing :-)

Thanks for letting us know!


-- 
Martín Ferrari (Tincho)

--- End Message ---
_______________________________________________
Pkg-go-maintainers mailing list
Pkg-go-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers

Reply via email to