Hi all,

I have noticed that the ppc64 build for a Go package I co-maintain failed [1] 
with the following error message:

[…]
go build github.com/google/stenographer/blockfile: no buildable Go source files 
in 
/<<PKGBUILDDIR>>/obj-powerpc64-linux-gnu/src/github.com/google/stenographer/blockfile
[…]

while all other supported archs are unaffected and build fine [2]. Any ideas? I 
can reproduce the issue on pizzetti.debian.org.
The only thing that struck me as out of the ordinary is that the package in 
question uses C components and the ppc64 build seems to be missing support for 
cgo. At least /usr/lib/go-1.7/pkg/linux_ppc64/runtime/cgo.a seems to be 
missing? (Maybe I’m way off here…)

If that is indeed the problem I’d be happy to remove ppc64 from the list of 
supported archs.

Thanks and kind regards
Sascha


[1] 
https://buildd.debian.org/status/fetch.php?pkg=stenographer&arch=ppc64&ver=0.0~git20161206.0.66a8e7e-4&stamp=1485220126&raw=0
[2] https://buildd.debian.org/status/package.php?p=stenographer

Attachment: signature.asc
Description: Message signed with OpenPGP

_______________________________________________
Pkg-go-maintainers mailing list
Pkg-go-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers

Reply via email to