On Wed, 2017-06-21 at 01:39 -0700, Michael Stapelberg wrote: > > > > On Wed, Jun 21, 2017 at 1:21 AM, Ian Campbell <i...@debian.org> wrote: > > On Wed, 2017-06-21 at 06:28 +0200, Guillem Jover wrote: > > > Hi! > > > > > > On Tue, 2017-06-20 at 09:49:26 +0200, Michael Stapelberg wrote: > > > > > > > > Guillem Jover <guil...@debian.org> writes: > > > > > Please document at least the variables from the environment that > > > > > directly affect the behavior such as GOPATH, DH_GOPKG, > > > > > DH_GOLANG_INSTALL_ALL, DH_GOLANG_INSTALL_EXTRA, DH_GOLANG_BUILDPKG, > > > > > DH_GOLANG_GO_GENERATE. And the field control field Go-Import-Path. > > > > > > > > What’s the correct place to document them? Stuffing this buildsystem > > > > related documentation into the dh_golang(1) manpage seems inappropriate, > > > > as that manpage should only document the dh_golang executable, right? > > > > > > Yeah, that was my initial reaction as well. And I'm not sure where > > > the buildsystem and sequence behavior is supposed to be documented, or > > > whether debhelper maintainers would recommend doing so, so I've CCed > > > them in case they have any input. > > > > > > OTOH, dh_golang(1p) already contains a brief note about the golang > > > buildsystem, so perhaps that man page is not such a bad idea after > > > all? Also because that's the entry point for the command, but yeah > > > as mentioned above I also see why it feels wrong. > > > > Are DH_GOLANG_* not as specific to dh_golang as the name would suggest? > > They’re specific to the debhelper golang buildsystem > (/usr/share/perl5/Debian/Debhelper/Buildsystem/golang.pm). Should > they be named differently?
I hadn't realised there was that distinction between the library and the tool, so I don't know, you should probably ignore me ;-) Ian. _______________________________________________ Pkg-go-maintainers mailing list Pkgemail@example.com http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers