Package: golang-github-coreos-go-semver-dev
Version: 0.0~git20150304-2
Severity: serious
User: debian...@lists.debian.org
Usertags: piuparts
Control: affects -1 + golang-go-semver-dev

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'stretch'.
It installed fine in 'stretch', then the upgrade to 'buster' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
https://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package golang-github-coreos-go-semver-dev.
  Preparing to unpack 
.../golang-github-coreos-go-semver-dev_0.0~git20150304-2_all.deb ...
  Unpacking golang-github-coreos-go-semver-dev (0.0~git20150304-2) ...
  dpkg: error processing archive 
/var/cache/apt/archives/golang-github-coreos-go-semver-dev_0.0~git20150304-2_all.deb
 (--unpack):
   trying to overwrite 
'/usr/share/gocode/src/github.com/coreos/go-semver/example.go', which is also 
in package golang-go-semver-dev 0.0~git20150304-1
  Preparing to unpack .../golang-go-semver-dev_0.0~git20150304-2_all.deb ...
  Unpacking golang-go-semver-dev (0.0~git20150304-2) over (0.0~git20150304-1) 
...
  Errors were encountered while processing:
   
/var/cache/apt/archives/golang-github-coreos-go-semver-dev_0.0~git20150304-2_all.deb


cheers,

Andreas

Attachment: golang-go-semver-dev_0.0~git20150304-2.log.gz
Description: application/gzip

_______________________________________________
Pkg-go-maintainers mailing list
Pkg-go-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers

Reply via email to