Your message dated Wed, 13 Sep 2017 09:00:42 +0100
with message-id <>
and subject line Re: Bug#850415: dnss: FTBFS randomly (failing tests)
has caused the Debian Bug report #850415,
regarding dnss: FTBFS randomly (failing tests)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: src:dnss
Version: 0.0~git20161126.0.162090e-1
Severity: important

Dear maintainer:

I tried to build this package in stretch with "dpkg-buildpackage -B"
but it failed:

 debian/rules build-arch
dh build-arch --buildsystem=golang --with=golang --with=systemd
   dh_testdir -a -O--buildsystem=golang
   dh_update_autotools_config -a -O--buildsystem=golang
   dh_auto_configure -a -O--buildsystem=golang
   dh_auto_build -a -O--buildsystem=golang
        go install -v -p 1

[... snipped ...]

        util.go:66: trace 0xc42002c8b8: cache hit
        util.go:66: trace 0xc42002c8c0: cache hit
        util.go:66: trace 0xc42002c8c8: cache hit
        util.go:66: trace 0xc42002c8d0: cache hit
        util.go:66: trace 0xc42002c8d8: cache hit
        util.go:66: trace 0xc42002c8e0: cache hit
        util.go:66: trace 0xc42002c8e8: cache hit
        util.go:66: trace 0xc42002c8f0: cache hit
        util.go:66: trace 0xc42002c8f8: cache hit
        util.go:66: trace 0xc42002c900: cache hit
        util.go:66: trace 0xc42002c908: cache hit
        util.go:66: trace 0xc42002c910: cache hit
        util.go:66: trace 0xc42002c918: cache hit
        util.go:66: trace 0xc42002c920: cache hit
        util.go:66: trace 0xc42002c928: cache miss
=== RUN   TestZeroSize
--- PASS: TestZeroSize (0.00s)
        util.go:66: trace 0xc42002c938: cache miss
        util.go:66: trace 0xc42002c940: cache miss
        util.go:66: trace 0xc42002c948: cache miss
        util.go:66: trace 0xc42002c950: cache miss
        util.go:66: trace 0xc42002c958: cache miss
        util.go:66: trace 0xc42002c960: cache miss
        util.go:66: trace 0xc42002c968: cache miss
        util.go:66: trace 0xc42002c970: cache miss
        util.go:66: trace 0xc42002c978: cache miss
        util.go:66: trace 0xc42002c980: cache miss
ok  0.133s
?       [no test files]
?   [no test files]
?    [no test files]
=== RUN   TestSimple
--- PASS: TestSimple (0.00s)
ok     0.210s
=== RUN   TestSimple
--- PASS: TestSimple (0.00s)
ok    0.143s
?     [no test files]
dh_auto_test: go test -v -p 1 
returned exit code 1
debian/rules:4: recipe for target 'build-arch' failed
make: *** [build-arch] Error 1
dpkg-buildpackage: error: debian/rules build-arch gave error exit status 2

This is just how the build ends, not necessarily the relevant part.

I've put several build logs here:

If this is really a bug in one of the build-depends, please use reassign and 
so that this is still visible in the page for this package.

The bug should be reproducible with sbuild on a single CPU virtual machine,
provided you try enough times (as the failure happens randomly).


--- End Message ---
--- Begin Message ---
Package: src:dnss
Version: 0.0~git20170810.0.860d2af1-1

On Fri, Jan 06, 2017 at 10:19:03AM +0000, Santiago Vila wrote:
> Package: src:dnss
> Version: 0.0~git20161126.0.162090e-1
> Severity: important
> Dear maintainer:
> I tried to build this package in stretch with "dpkg-buildpackage -B"
> but it failed:

Thanks for the report!

Sorry it took so long to reply, I thought this was going to be
automatically replied to but forgot to include the reference in the
changelog :S

The latest package, 0.0~git20170810.0.860d2af1-1, includes many changes
to the tests which should address the problems you were seeing.

In particular, the port hardcoding in the tests that was causing this
issues has been fixed, and now an available port is picked at runtime.


--- End Message ---
Pkg-go-maintainers mailing list

Reply via email to