I was able to build swarmkit on arm64 after I manually installed a
newer golang-github-docker-docker-dev.

There's some kind of circular dependency between swarmkit and
docker.io. I think someone will have to break it with a binary upload.
(There was a binary upload on amd64, I notice.)

According to my "history", I did something like:

apt-get build-dep docker.io
apt-get build-dep swarmkit
apt-get install golang-github-docker-docker-dev
wget 
http://ftp.uk.debian.org/debian/pool/main/d/docker.io/golang-github-docker-docker-dev_1.13.1~ds2-3_all.deb
dpkg -i golang-github-docker-docker-dev_1.13.1~ds2-3_all.deb
apt-get install golang-github-opencontainers-docker-runc-dev
apt --fix-broken install
dpkg -i golang-github-docker-docker-dev_1.13.1~ds2-3_all.deb
apt-get source swarmkit
cd swarmkit-1.12.0+git20170111.763.296fcfcf
dpkg-buildpackage -b

_______________________________________________
Pkg-go-maintainers mailing list
Pkg-go-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers

Reply via email to