control: forwarded -1 https://github.com/pytroll/satpy/pull/1045
control: tags -1 fixed-upstream
Hello


https://github.com/pytroll/satpy/pull/1045

Here you can find the discussion related

and here a build log of a failure:
https://launchpadlibrarian.net/464927743/buildlog_ubuntu-focal-amd64.satpy_0.19.1-2_BUILDING.txt.gz

INFO:satpy.readers:Cannot use 
['/<<PKGBUILDDIR>>/satpy/etc/readers/avhrr_l1b_hrpt.yaml']
DEBUG:satpy.readers:while constructing a Python object
cannot find module 'satpy.readers.hrpt' (No module named 
'pygac.gac_calibration')
  in "<unicode string>", line 93, column 22:
            file_reader: !!python/name:satpy.readers.hrpt ... 
                         ^
DEBUG:satpy.readers:Reading ['/<<PKGBUILDDIR>>/satpy/etc/readers/ami_l1b.yaml']

(note: Ubuntu default to python3.8, so this might be a reason for you not yet 
failing the build process)

Looks like there is a new build error today, funny

G.

On Wed, 22 Jan 2020 08:41:33 +0100 Antonio Valentino 
<antonio.valent...@tiscali.it> wrote:
> Dear Gianfranco,
> 
> On Tue, 21 Jan 2020 18:03:01 +0100 Gianfranco Costamagna
> <locutusofb...@debian.org> wrote:
> > control: severity -1 important
> > 
> > On Tue, 21 Jan 2020 09:28:40 +0100 Gianfranco Costamagna 
> > <locutusofb...@debian.org> wrote:
> > > Source: satpy
> > > Version: 0.19.1-1
> > > Severity: serious
> > > 
> > > Hello, looks like pygac update regressed the testsuite.
> > > I requested a new run in Debian, but in the meanwhile you can see a run 
> > > here:
> > > https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal/focal/amd64/s/satpy/20200120_195040_eac9b@/log.gz
> > > 
> > > or here:
> > > http://debomatic-amd64.debian.net/distribution#unstable/satpy/0.19.1-1/autopkgtest
> > > 
> > > (and even inside the build process itself the error is thrown out, but 
> > > for some reasons the testsuite errors are somewhat ignored at least in 
> > > that part)
> > > 
> > 
> > looks like the debian autopkgtest is green, and the "killed" is an 
> > ubuntu-only thing.
> > 
> > However, my patch has been merged upstream, so the gac issue is fixed.
> > 
> > G.
> 
> 
> Sorry Gianfranco but the problem is not clear to me.
> 
> Apart for the killed test run, satpy is failing in testing due to a
> missing dependency (behave) which has been removed form testing.
> 
> I don't see any issue related to pygac, am I missing something?
> 
> Also can you please give me a pointer to the patch that has been merged
> upstream?
> 
> 
> kind regards
> 
> -- 
> Antonio Valentino
> 
> 

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to