User: pere    
  Date: 05/11/13 17:13:24

  Modified:    debian   changelog control php4-mapscript.config
                        php4-mapscript.postinst php4-mapscript.prerm
                        php4-mapscript.templates rules
  Added:       debian   php5-mapscript.config php5-mapscript.dirs
                        php5-mapscript.files php5-mapscript.postinst
                        php5-mapscript.prerm php5-mapscript.templates
  Log:
     [ Petter Reinholdtsen ]
     * Add support for php5 mapscript.  New binary package
       php5-mapscript.  Based on patch from Jon Saints.
     * Renamed templates name from php4/* to php4-mapscript/* to match
       package name.
     * Fix typo 'Curently'->'Currently' in package description.
  
  Revision  Changes    Path
  1.39      +11 -0     mapserver/debian/changelog
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/changelog?annotate=1.39&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/changelog?rev=1.39&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/changelog.diff?r1=1.39&r2=1.38&cvsroot=
  
  -----------------------------------
  
  Index: changelog
  ===================================================================
  RCS file: /cvsroot/pkg-grass/mapserver/debian/changelog,v
  retrieving revision 1.38
  retrieving revision 1.39
  diff -u -r1.38 -r1.39
  --- changelog 4 Nov 2005 23:49:42 -0000       1.38
  +++ changelog 13 Nov 2005 17:13:24 -0000      1.39
  @@ -1,3 +1,14 @@
  +mapserver (4.6.1-5) UNRELEASED; urgency=low
  +
  +  [ Petter Reinholdtsen ]
  +  * Add support for php5 mapscript.  New binary package
  +    php5-mapscript.  Based on patch from Jon Saints.
  +  * Renamed templates name from php4/* to php4-mapscript/* to match
  +    package name.
  +  * Fix typo 'Curently'->'Currently' in package description.
  +
  + -- Petter Reinholdtsen <[EMAIL PROTECTED]>  Sun, 13 Nov 2005 18:04:59 +0100
  +
   mapserver (4.6.1-4) unstable; urgency=low
   
     * Add Swedish translation by Daniel Nylander. (Closes: #333097)
  
  
  
  1.25      +13 -2     mapserver/debian/control
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/control?annotate=1.25&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/control?rev=1.25&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/control.diff?r1=1.25&r2=1.24&cvsroot=
  
  -----------------------------------
  
  Index: control
  ===================================================================
  RCS file: /cvsroot/pkg-grass/mapserver/debian/control,v
  retrieving revision 1.24
  retrieving revision 1.25
  diff -u -r1.24 -r1.25
  --- control   4 Nov 2005 23:49:42 -0000       1.24
  +++ control   13 Nov 2005 17:13:24 -0000      1.25
  @@ -4,7 +4,7 @@
   Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
   Uploaders: Thomas Sondag <[EMAIL PROTECTED]>, Schuyler Erle <[EMAIL 
PROTECTED]>, Petter Reinholdtsen <[EMAIL PROTECTED]>
   Standards-Version: 3.6.2.1
  -Build-Depends: debhelper (>= 4), dpatch, libcurl3-gnutls-dev | libcurl3-dev, 
libpng12-dev, zlib1g-dev (>= 1.1.4), libgd2-xpm-dev (>= 2.0.1-10), 
libfreetype6-dev (>=2.0.9), libjpeg62-dev, libgdal1-dev, proj, libwww-dev, 
postgresql-dev (>= 7.3.3-1), php4-dev, swig, python-dev
  +Build-Depends: debhelper (>= 4), dpatch, libcurl3-gnutls-dev | libcurl3-dev, 
libpng12-dev, zlib1g-dev (>= 1.1.4), libgd2-xpm-dev (>= 2.0.1-10), 
libfreetype6-dev (>=2.0.9), libjpeg62-dev, libgdal1-dev, proj, libwww-dev, 
postgresql-dev (>= 7.3.3-1), php4-dev, php5-dev, swig, python-dev
   Build-conflicts: libcurl3-openssl-dev
   
   Package: php4-mapscript
  @@ -19,7 +19,18 @@
    php mapscript allows you to use the mapserver functionalities with php web
    scripting language.
    .
  - Curently work only with php as an Apache DSO.
  + Currently work only with php as an Apache DSO.
  +
  +Package: php5-mapscript
  +Section: web
  +Architecture: any
  +Depends: ${shlibs:Depends}, ${misc:Depends}, libapache-mod-php5 | 
phpapi-20041030
  +Suggests: mapserver-bin, mapserver-doc
  +Description: module for php5-cgi to use mapserver
  + php mapscript allows you to use the mapserver functionalities with php web
  + scripting language.
  + .
  + Currently work only with php as an Apache DSO.
   
   Package: perl-mapscript
   Section: perl
  
  
  
  1.2       +10 -8     mapserver/debian/php4-mapscript.config
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.config?annotate=1.2&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.config?rev=1.2&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.config.diff?r1=1.2&r2=1.1&cvsroot=
  
  -----------------------------------
  
  Index: php4-mapscript.config
  ===================================================================
  RCS file: /cvsroot/pkg-grass/mapserver/debian/php4-mapscript.config,v
  retrieving revision 1.1
  retrieving revision 1.2
  diff -u -r1.1 -r1.2
  --- php4-mapscript.config     23 Jan 2005 18:15:39 -0000      1.1
  +++ php4-mapscript.config     13 Nov 2005 17:13:24 -0000      1.2
  @@ -5,27 +5,29 @@
   
   db_title "PHP"
   
  +phpver=php4
  +
   for SAPI in apache
   do
        # Skip this loop if the config file isn't there (yet).
  -     if [ -f "/etc/php4/$SAPI/php.ini" ]; then
  -             db_register php4/add_extension php4/extension_mapscript_$SAPI
  +     if [ -f "/etc/$phpver/$SAPI/php.ini" ]; then
  +             db_register $phpver/add_extension 
$phpver/extension_mapscript_$SAPI
   
                # FIXME: this is the wrong answer if the SAPI package was
                # installed after the module was.
                if [ -n "$2" ] && dpkg --compare-versions "$2" ge 4:4.3.2+rc3-2
                then
  -                     if grep -q 
"^[[:space:]]*extension[[:space:]]*=[[:space:]]*php_mapscript.so" 
"/etc/php4/$SAPI/php.ini"
  +                     if grep -q 
"^[[:space:]]*extension[[:space:]]*=[[:space:]]*php_mapscript.so" 
"/etc/$phpver/$SAPI/php.ini"
                        then
  -                             db_set php4/extension_mapscript_$SAPI true
  +                             db_set $phpver/extension_mapscript_$SAPI true
                        else
  -                             db_set php4/extension_mapscript_$SAPI false
  +                             db_set $phpver/extension_mapscript_$SAPI false
                        fi
                fi
   
  -             db_subst php4/extension_mapscript_$SAPI extname Mapscript 
  -             db_subst php4/extension_mapscript_$SAPI sapiconfig $SAPI
  -             db_input low php4/extension_mapscript_$SAPI || true
  +             db_subst $phpver/extension_mapscript_$SAPI extname Mapscript 
  +             db_subst $phpver/extension_mapscript_$SAPI sapiconfig $SAPI
  +             db_input low $phpver/extension_mapscript_$SAPI || true
        fi
   done
   
  
  
  
  1.2       +6 -4      mapserver/debian/php4-mapscript.postinst
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.postinst?annotate=1.2&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.postinst?rev=1.2&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.postinst.diff?r1=1.2&r2=1.1&cvsroot=
  
  -----------------------------------
  
  Index: php4-mapscript.postinst
  ===================================================================
  RCS file: /cvsroot/pkg-grass/mapserver/debian/php4-mapscript.postinst,v
  retrieving revision 1.1
  retrieving revision 1.2
  diff -u -r1.1 -r1.2
  --- php4-mapscript.postinst   23 Jan 2005 18:15:39 -0000      1.1
  +++ php4-mapscript.postinst   13 Nov 2005 17:13:24 -0000      1.2
  @@ -11,14 +11,16 @@
        exit 0
   fi
   
  +phpver=php4
  +
   for SAPI in apache
   do
  -     if [ -f /etc/php4/$SAPI/php.ini ]; then
  -             db_get php4/extension_mapscript_$SAPI
  +     if [ -f /etc/$phpver/$SAPI/php.ini ]; then
  +             db_get $phpver/extension_mapscript_$SAPI
                if [ "$RET" = "true" ] \
  -                && ! grep -q 
"^[[:space:]]*extension[[:space:]]*=[[:space:]]*php_mapscript.so" 
/etc/php4/$SAPI/php.ini
  +                && ! grep -q 
"^[[:space:]]*extension[[:space:]]*=[[:space:]]*php_mapscript.so" 
/etc/$phpver/$SAPI/php.ini
                then
  -                     echo "extension=php_mapscript.so" >> 
/etc/php4/$SAPI/php.ini
  +                     echo "extension=php_mapscript.so" >> 
/etc/$phpver/$SAPI/php.ini
                fi
        fi
   done
  
  
  
  1.3       +17 -15    mapserver/debian/php4-mapscript.prerm
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.prerm?annotate=1.3&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.prerm?rev=1.3&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.prerm.diff?r1=1.3&r2=1.2&cvsroot=
  
  -----------------------------------
  
  Index: php4-mapscript.prerm
  ===================================================================
  RCS file: /cvsroot/pkg-grass/mapserver/debian/php4-mapscript.prerm,v
  retrieving revision 1.2
  retrieving revision 1.3
  diff -u -r1.2 -r1.3
  --- php4-mapscript.prerm      11 Sep 2005 09:15:08 -0000      1.2
  +++ php4-mapscript.prerm      13 Nov 2005 17:13:24 -0000      1.3
  @@ -12,30 +12,32 @@
   
   . /usr/share/debconf/confmodule
   
  -for SAPI in `find /etc/php4/ -type d -maxdepth 1 -mindepth 1 | sed 
-e's#.*/##'`
  +phpver=php4
  +
  +for SAPI in `find /etc/$phpver/ -type d -maxdepth 1 -mindepth 1 | sed 
-e's#.*/##'`
   do
        # Use the same question for all extensions, because it's only
        # used once per package: right here.
  -     if [ -f "/etc/php4/$SAPI/php.ini" ] \
  -        && grep -q "$EXTENSIONRE" /etc/php4/$SAPI/php.ini
  +     if [ -f "/etc/$phpver/$SAPI/php.ini" ] \
  +        && grep -q "$EXTENSIONRE" /etc/$phpver/$SAPI/php.ini
        then
  -             db_set php4/remove_extension true
  +             db_set $phpver/remove_extension true
                db_title "PHP"
  -             db_subst php4/remove_extension extname Mapscript
  -             db_subst php4/remove_extension sapiconfig $SAPI
  -             db_input low php4/remove_extension || true
  +             db_subst $phpver/remove_extension extname Mapscript
  +             db_subst $phpver/remove_extension sapiconfig $SAPI
  +             db_input low $phpver/remove_extension || true
                db_go
   
  -             db_get php4/remove_extension
  +             db_get $phpver/remove_extension
                if [ "$RET" = "true" ]; then
  -                     grep -v "$EXTENSIONRE" < /etc/php4/$SAPI/php.ini \
  -                             > /etc/php4/$SAPI/php.ini.mapscriptremove
  -                     chmod --reference=/etc/php4/$SAPI/php.ini \
  -                             /etc/php4/$SAPI/php.ini.mapscriptremove
  -                     mv /etc/php4/$SAPI/php.ini.mapscriptremove \
  -                             /etc/php4/$SAPI/php.ini
  +                     grep -v "$EXTENSIONRE" < /etc/$phpver/$SAPI/php.ini \
  +                             > /etc/$phpver/$SAPI/php.ini.mapscriptremove
  +                     chmod --reference=/etc/$phpver/$SAPI/php.ini \
  +                             /etc/$phpver/$SAPI/php.ini.mapscriptremove
  +                     mv /etc/$phpver/$SAPI/php.ini.mapscriptremove \
  +                             /etc/$phpver/$SAPI/php.ini
                fi
  -             db_fset php4/remove_extension seen false
  +             db_fset $phpver/remove_extension seen false
        fi
   done
   
  
  
  
  1.3       +2 -2      mapserver/debian/php4-mapscript.templates
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.templates?annotate=1.3&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.templates?rev=1.3&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php4-mapscript.templates.diff?r1=1.3&r2=1.2&cvsroot=
  
  -----------------------------------
  
  Index: php4-mapscript.templates
  ===================================================================
  RCS file: /cvsroot/pkg-grass/mapserver/debian/php4-mapscript.templates,v
  retrieving revision 1.2
  retrieving revision 1.3
  diff -u -r1.2 -r1.3
  --- php4-mapscript.templates  30 Mar 2005 22:35:18 -0000      1.2
  +++ php4-mapscript.templates  13 Nov 2005 17:13:24 -0000      1.3
  @@ -1,4 +1,4 @@
  -Template: php4/add_extension
  +Template: php4-mapscript/add_extension
   Type: boolean
   Default: true
   _Description: Should ${extname} be added to /etc/php4/${sapiconfig}/php.ini?
  @@ -6,7 +6,7 @@
    enabled in the configuration for the ${sapiconfig} SAPI.  Do you want
    this extension to be enabled now?
   
  -Template: php4/remove_extension
  +Template: php4-mapscript/remove_extension
   Type: boolean
   Default: true
   _Description: Should ${extname} be removed from 
/etc/php4/${sapiconfig}/php.ini?
  
  
  
  1.12      +33 -7     mapserver/debian/rules
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/rules?annotate=1.12&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/rules?rev=1.12&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/rules.diff?r1=1.12&r2=1.11&cvsroot=
  
  -----------------------------------
  
  Index: rules
  ===================================================================
  RCS file: /cvsroot/pkg-grass/mapserver/debian/rules,v
  retrieving revision 1.11
  retrieving revision 1.12
  diff -u -r1.11 -r1.12
  --- rules     2 Aug 2005 10:16:14 -0000       1.11
  +++ rules     13 Nov 2005 17:13:24 -0000      1.12
  @@ -52,13 +52,20 @@
   
        touch configure-stamp
   
  -configure-php-stamp: patch clean-first-build
  +configure-php4-stamp: patch clean-first-build
        dh_testdir
        ./configure $(COMMON_CONFIG) \
                --with-php=/usr/include/php4 \
                --with-php-regex-dir=/usr/include/php4/regex
   
  -     touch configure-php-stamp
  +     touch configure-php4-stamp
  +
  +configure-php5-stamp: patch clean-first-build
  +     dh_testdir
  +     ./configure $(COMMON_CONFIG) \
  +             --with-php=/usr/include/php5 
  +
  +     touch configure-php5-stamp
   
   build-stamp: configure-stamp mapscriptvars
        dh_testdir
  @@ -77,12 +84,19 @@
   
        touch build-stamp
   
  -build-php-stamp: configure-php-stamp
  +build-php4-stamp: configure-php4-stamp
        dh_testdir
   
        # Build php_mapscript
        $(MAKE)
   
  +build-php5-stamp: configure-php5-stamp
  +     dh_testdir
  +     -cd mapscript/php3 && \
  +             $(MAKE) clean
  +     # Build php_mapscript
  +     $(MAKE)
  +
   # This is needed to do 'make clean', but will be removed by the clean
   # targets.  The end result is that 'debuild clean' only can execute
   # once.  Hack around this problem by faking the creation when make fail.
  @@ -117,11 +131,11 @@
   clean: unpatch clean-first-build
        dh_testdir
        dh_clean
  -     -$(RM) configure-phpstamp build-php-stamp install-stamp 
install-php-stamp
  +     -$(RM) configure-php4-stamp configure-php5-stamp build-php4-stamp 
build-php5-stamp install-stamp install-php4-stamp install-php5-stamp
        -$(MAKE) distclean
   
   
  -install: install-stamp install-php-stamp
  +install: install-stamp install-php4-stamp install-php5-stamp
   install-stamp: build-stamp
        dh_testdir
        dh_testroot
  @@ -151,7 +165,7 @@
        touch install-stamp
   
   
  -install-php-stamp: build-php-stamp
  +install-php4-stamp: build-php4-stamp
        dh_testdir
        dh_testroot
   
  @@ -161,7 +175,19 @@
        install -m644 mapscript/php3/php_mapscript.so \
                debian/tmp/usr/lib/php4/20020429
                         
  -     touch install-php-stamp
  +     touch install-php4-stamp
  +
  +install-php5-stamp: build-php5-stamp
  +     dh_testdir
  +     dh_testroot
  +
  +     -mkdir -p debian/tmp/usr/lib/php5/20041030
  +
  +     # php5-mapscript
  +     install -m644 mapscript/php3/php_mapscript.so \
  +             debian/tmp/usr/lib/php5/20041030
  +                      
  +     touch install-php5-stamp
   
   binary-indep: install 
   
  
  
  
  1.1                  mapserver/debian/php5-mapscript.config
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.config?annotate=1.1&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.config?rev=1.1&content-type=text/x-cvsweb-markup&cvsroot=
  
  -----------------------------------
  
  Index: php5-mapscript.config
  ===================================================================
  #/bin/sh -e
  
  # Source debconf library.
  . /usr/share/debconf/confmodule
  
  db_title "PHP"
  
  phpver=php5
  
  for SAPI in apache
  do
        # Skip this loop if the config file isn't there (yet).
        if [ -f "/etc/$phpver/$SAPI/php.ini" ]; then
                db_register $phpver/add_extension 
$phpver/extension_mapscript_$SAPI
  
                # FIXME: this is the wrong answer if the SAPI package was
                # installed after the module was.
                if [ -n "$2" ] && dpkg --compare-versions "$2" ge 4:4.3.2+rc3-2
                then
                        if grep -q 
"^[[:space:]]*extension[[:space:]]*=[[:space:]]*php_mapscript.so" 
"/etc/$phpver/$SAPI/php.ini"
                        then
                                db_set $phpver/extension_mapscript_$SAPI true
                        else
                                db_set $phpver/extension_mapscript_$SAPI false
                        fi
                fi
  
                db_subst $phpver/extension_mapscript_$SAPI extname Mapscript 
                db_subst $phpver/extension_mapscript_$SAPI sapiconfig $SAPI
                db_input low $phpver/extension_mapscript_$SAPI || true
        fi
  done
  
  db_go
  
  
  
  1.1                  mapserver/debian/php5-mapscript.dirs
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.dirs?annotate=1.1&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.dirs?rev=1.1&content-type=text/x-cvsweb-markup&cvsroot=
  
  -----------------------------------
  
  Index: php5-mapscript.dirs
  ===================================================================
  usr/lib/php5/20041030/
  
  
  
  1.1                  mapserver/debian/php5-mapscript.files
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.files?annotate=1.1&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.files?rev=1.1&content-type=text/x-cvsweb-markup&cvsroot=
  
  -----------------------------------
  
  Index: php5-mapscript.files
  ===================================================================
  usr/lib/php5/20041030/
  
  
  
  1.1                  mapserver/debian/php5-mapscript.postinst
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.postinst?annotate=1.1&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.postinst?rev=1.1&content-type=text/x-cvsweb-markup&cvsroot=
  
  -----------------------------------
  
  Index: php5-mapscript.postinst
  ===================================================================
  #!/bin/sh
  
  set -e
  
  # Source debconf library.
  . /usr/share/debconf/confmodule
  
  #DEBHELPER#
  
  if [ "$1" != "configure" ]; then
        exit 0
  fi
  
  phpver=php5
  
  for SAPI in apache
  do
        if [ -f /etc/$phpver/$SAPI/php.ini ]; then
                db_get $phpver/extension_mapscript_$SAPI
                if [ "$RET" = "true" ] \
                   && ! grep -q 
"^[[:space:]]*extension[[:space:]]*=[[:space:]]*php_mapscript.so" 
/etc/$phpver/$SAPI/php.ini
                then
                        echo "extension=php_mapscript.so" >> 
/etc/$phpver/$SAPI/php.ini
                fi
        fi
  done
  
  exit 0
  
  
  
  1.1                  mapserver/debian/php5-mapscript.prerm
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.prerm?annotate=1.1&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.prerm?rev=1.1&content-type=text/x-cvsweb-markup&cvsroot=
  
  -----------------------------------
  
  Index: php5-mapscript.prerm
  ===================================================================
  #!/bin/sh
  
  set -e
  
  #DEBHELPER#
  
  if [ "$1" != "remove" ] && [ "$1" != "purge" ]; then
        exit 0
  fi
  
  EXTENSIONRE="^[[:space:]]*extension[[:space:]]*=[[:space:]]*php_mapscript.so"
  
  . /usr/share/debconf/confmodule
  
  phpver=php5
  
  for SAPI in `find /etc/$phpver/ -type d -maxdepth 1 -mindepth 1 | sed 
-e's#.*/##'`
  do
        # Use the same question for all extensions, because it's only
        # used once per package: right here.
        if [ -f "/etc/$phpver/$SAPI/php.ini" ] \
           && grep -q "$EXTENSIONRE" /etc/$phpver/$SAPI/php.ini
        then
                db_set $phpver/remove_extension true
                db_title "PHP"
                db_subst $phpver/remove_extension extname Mapscript
                db_subst $phpver/remove_extension sapiconfig $SAPI
                db_input low $phpver/remove_extension || true
                db_go
  
                db_get $phpver/remove_extension
                if [ "$RET" = "true" ]; then
                        grep -v "$EXTENSIONRE" < /etc/$phpver/$SAPI/php.ini \
                                > /etc/$phpver/$SAPI/php.ini.mapscriptremove
                        chmod --reference=/etc/$phpver/$SAPI/php.ini \
                                /etc/$phpver/$SAPI/php.ini.mapscriptremove
                        mv /etc/$phpver/$SAPI/php.ini.mapscriptremove \
                                /etc/$phpver/$SAPI/php.ini
                fi
                db_fset $phpver/remove_extension seen false
        fi
  done
  
  exit 0
  
  
  
  1.1                  mapserver/debian/php5-mapscript.templates
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.templates?annotate=1.1&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/mapserver/debian/php5-mapscript.templates?rev=1.1&content-type=text/x-cvsweb-markup&cvsroot=
  
  -----------------------------------
  
  Index: php5-mapscript.templates
  ===================================================================
  Template: php5-mapscript/add_extension
  Type: boolean
  Default: true
  _Description: Should ${extname} be added to /etc/php5/${sapiconfig}/php.ini?
   You are installing ${extname} support for php5, and it is not yet
   enabled in the configuration for the ${sapiconfig} SAPI.  Do you want
   this extension to be enabled now?
  
  Template: php5-mapscript/remove_extension
  Type: boolean
  Default: true
  _Description: Should ${extname} be removed from 
/etc/php5/${sapiconfig}/php.ini?
   You are removing ${extname} support for php5, but it is still enabled
   in the configuration for the ${sapiconfig} SAPI.  Leaving this in place
   will probably cause problems when trying to use PHP.
  
  
  

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to