tags 339007 + patch
thanks

I've attached a patch to fix the php4-mapscript bug (which has the
potential to affect php5-mapscript too). It installs to the correct
directory and adds the correct ${misc:Depends} for the right phpapi
virtual package. It *does not* modify php.ini like the maintainer
scripts for php4-sqlite/dh_pecl do.

Incidentally, dh_pecl from php4-sqlite should probably be moved into
debhelper so other packages can benefit from it. 

-- 
bye,
pabs

http://wiki.debian.org/PaulWise
diff -u mapserver-4.6.1/debian/changelog mapserver-4.6.1/debian/changelog
--- mapserver-4.6.1/debian/changelog
+++ mapserver-4.6.1/debian/changelog
@@ -1,3 +1,10 @@
+mapserver (4.6.1-6) unstable; urgency=low
+
+  * Install php extensions into the directory output by php-configN and depend
+    on the phpapi virtual package specified by php-configN (Closes: #339007)
+
+ -- Paul Wise <[EMAIL PROTECTED]>  Sat, 19 Nov 2005 13:10:09 +0800
+
 mapserver (4.6.1-5) unstable; urgency=low
 
   [ Petter Reinholdtsen ]
diff -u mapserver-4.6.1/debian/control mapserver-4.6.1/debian/control
--- mapserver-4.6.1/debian/control
+++ mapserver-4.6.1/debian/control
@@ -11,7 +11,7 @@
 Section: web
 Priority: extra
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libapache-mod-php4 | phpapi-20020918
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Suggests: mapserver-bin, mapserver-doc
 Replaces: php-mapscript
 Conflicts: php-mapscript
@@ -24,7 +24,7 @@
 Package: php5-mapscript
 Section: web
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libapache-mod-php5 | phpapi-20041030
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Suggests: mapserver-bin, mapserver-doc
 Description: module for php5-cgi to use mapserver
  php mapscript allows you to use the mapserver functionalities with php web
diff -u mapserver-4.6.1/debian/rules mapserver-4.6.1/debian/rules
--- mapserver-4.6.1/debian/rules
+++ mapserver-4.6.1/debian/rules
@@ -17,6 +17,10 @@
 version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
 CURDIR := $(shell pwd)
 PYTHON=python
+PHP4API=$(shell php-config4 --phpapi)
+PHP4DIR=$(shell php-config4 --extension-dir)
+PHP5API=$(shell php-config5 --phpapi)
+PHP5DIR=$(shell php-config5 --extension-dir)
 
 # Configure config :
 # Not using non free libpdf
@@ -169,11 +173,13 @@
 	dh_testdir
 	dh_testroot
 
-	-mkdir -p debian/tmp/usr/lib/php4/20020429
+	-mkdir -p debian/tmp$(PHP4DIR)
 
 	# php4-mapscript
 	install -m644 mapscript/php3/php_mapscript.so \
-		debian/tmp/usr/lib/php4/20020429
+		debian/tmp$(PHP4DIR)
+
+	echo 'misc:Depends=phpapi-'$(PHP4API) >> debian/php4-mapscript.substvars
                       
 	touch install-php4-stamp
 
@@ -181,12 +187,14 @@
 	dh_testdir
 	dh_testroot
 
-	-mkdir -p debian/tmp/usr/lib/php5/20041030
+	-mkdir -p debian/tmp$(PHP5DIR)
 
 	# php5-mapscript
 	install -m644 mapscript/php3/php_mapscript.so \
-		debian/tmp/usr/lib/php5/20041030
+		debian/tmp$(PHP5DIR)
                       
+	echo 'misc:Depends=phpapi-'$(PHP5API) >> debian/php5-mapscript.substvars
+
 	touch install-php5-stamp
 
 binary-indep: install 

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to