tags 352844 + moreinfo
tags 352844 + unreproducible
tags 352844 + important
thanks

I'm not a python addicted, anyway it starts perfectly here.
Has someone hints about that exception? It could be due to some wx anomalies
(maybe with your libc release). Would you please try with a fresh sid install?


On Tue, Feb 14, 2006 at 05:58:28PM +0100, Laurent Bonnaud wrote:
> Package: thuban
> Version: 1.0.1-1
> Severity: grave
> Justification: renders package unusable
> 
> 
> Hi,
> 
> here is the problem:
> 
> $ thuban
> Traceback (most recent call last):
>   File "/usr/bin/thuban", line 20, in ?
>     import Thuban.UI.main
>   File "/usr/lib/thuban/Thuban/UI/main.py", line 18, in ?
>     from application import ThubanApplication
>   File "/usr/lib/thuban/Thuban/UI/application.py", line 33, in ?
>     import view
>   File "/usr/lib/thuban/Thuban/UI/view.py", line 40, in ?
>     from renderer import ScreenRenderer, ExportRenderer, PrinterRenderer
>   File "/usr/lib/thuban/Thuban/UI/renderer.py", line 28, in ?
>     from Thuban.UI.classifier import ClassDataPreviewer
>   File "/usr/lib/thuban/Thuban/UI/classifier.py", line 1441, in ?
>     class ClassGroupPropertiesCtrl(wxWindow, wxControl):
> TypeError: Cannot create a consistent method resolution
> order (MRO) for bases Control, Window
> 
> 
> -- System Information:
> Debian Release: testing/unstable
>   APT prefers unstable
>   APT policy: (100, 'unstable'), (99, 'experimental')
> Architecture: i386 (i686)
> Shell:  /bin/sh linked to /bin/bash
> Kernel: Linux 2.6.15-1-686
> Locale: [EMAIL PROTECTED], [EMAIL PROTECTED] (charmap=ISO-8859-15)
> 
> Versions of packages thuban depends on:
> ii  gdal-bin                     1.3.1-4     Geospatial Data Abstraction 
> Librar
> ii  libc6                        2.3.6-1     GNU C Library: Shared libraries 
> an
> ii  libgcc1                      1:4.1-0exp7 GCC support library

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ experimental???

> ii  libgdal1-1.3.1               1.3.1-4     Geospatial Data Abstraction 
> Librar
> ii  libstdc++6                   4.1-0exp7   The GNU Standard C++ Library v3

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ again

> ii  libwxgtk2.4-1                2.4.4.1.1   wxWindows Cross-platform C++ GUI 
> t
> ii  proj                         4.4.9d-2    Cartographic projection filter 
> and
> ii  python [python-xmlbase]      2.3.5-5     An interactive high-level 
> object-o
> ii  python-sqlite                1.0.1-4     python interface to SQLite 2
> ii  python-wxgtk2.4              2.4.4.1.1   wxWindows Cross-platform C++ GUI 
> t
> 
> Versions of packages thuban recommends:
> ii  libgdal1-1.3.1                1.3.1-4    Geospatial Data Abstraction 
> Librar
> ii  python-gdal                   1.3.1-4    Python bindings to the 
> Geospatial 
> ii  python-psycopg                1.1.21-3   Python module for PostgreSQL 
> [dumm
> 
> -- no debconf information
> 
> 
> _______________________________________________
> Pkg-grass-devel mailing list
> Pkg-grass-devel@lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

-- 
Francesco P. Lovergine


_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to