User: mparent-guest
  Date: 06/03/28 11:46:14

  Modified:    .        create_package.sh
  Log:
  yada dependency check
  
  Revision  Changes    Path
  1.5       +13 -1     musmap/create_package.sh
  
  CVSWEB Options: -------------------
  
  CVSWeb: Annotate this file:            
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/musmap/create_package.sh?annotate=1.5&cvsroot=
  
  CVSWeb: View this file:             
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/musmap/create_package.sh?rev=1.5&content-type=text/x-cvsweb-markup&cvsroot=
  
  CVSWeb: Diff to previous version:   
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/pkg-grass/musmap/create_package.sh.diff?r1=1.5&r2=1.4&cvsroot=
  
  -----------------------------------
  
  Index: create_package.sh
  ===================================================================
  RCS file: /cvsroot/pkg-grass/musmap/create_package.sh,v
  retrieving revision 1.4
  retrieving revision 1.5
  diff -u -r1.4 -r1.5
  --- create_package.sh 28 Mar 2006 11:31:10 -0000      1.4
  +++ create_package.sh 28 Mar 2006 11:46:14 -0000      1.5
  @@ -11,8 +11,20 @@
   #target
   MUSMAP_TARGET="$MUSMAP_PKG_SOURCE/musmap-$MUSMAP_VERSION"
   
  +Q=`dpkg -s yada 2>/dev/null | egrep '^Status: ' `
  +if [ "x$Q" != "x" ]; then
  +  echo $Q | grep 'not-installed' > /dev/null 2>&1
  +  if [ $? != 0 ]; then
  +    YADA_VERSION=`dpkg -s yada | egrep '^Version: ' | sed -e 's/Version: //' 
2> /dev/null`
  +  fi
  +fi
  +
   case $1 in
     "")
  +    if [ "x$YADA_VERSION" = "x" ]; then
  +      echo "yada is required, run 'apt-get install yada' as root to install 
it"
  +      exit 1
  +    fi
       mkdir -v $MUSMAP_ORIG_TARGET
       cp -R $MUSMAP_SOURCE/* $MUSMAP_ORIG_TARGET
       #== cleaning
  
  
  

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to