Your message dated Sat, 08 Apr 2006 09:32:08 -0700
with message-id <[EMAIL PROTECTED]>
and subject line Bug#357189: fixed in gdal 1.3.1-5
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: gdal
Version: 1.3.1-4
Severity: important
Tags: patch

Your package fails to build with G++ 4.1.  I'm filing this bug as
important for now, but when 4.1 will be the default compiler in
unstable (probably in a few weeks) I'll upgrade this to serious.

A patch is below.

> Automatic build of gdal_1.3.1-4 on bigsur by sbuild/mips 1.94
> /bin/sh ../../libtool --mode=compile g++ -Wall  -O2   -I../../port 
> -I../../gcore -I../../alg -I../../ogr -I../../ogr/ogrsf_frmts  -I../../port  
> -c -o ../o/fitdataset.o fitdataset.cpp
>  g++ -Wall -O2 -I../../port -I../../gcore -I../../alg -I../../ogr 
> -I../../ogr/ogrsf_frmts -I../../port -c fitdataset.cpp  -fPIC -DPIC -o 
> ../o/.libs/fitdataset.o
> fitdataset.cpp:177: error: extra qualification 'FITRasterBand::' on member 
> 'FITRasterBand'
> fitdataset.cpp: In static member function 'static GDALDataset* 
> FITDataset::Open(GDALOpenInfo*)':
> fitdataset.cpp:1019: warning: dereferencing type-punned pointer will break 
> strict-aliasing rules
> make[3]: *** [../o/fitdataset.o] Error 1
> make[3]: Leaving directory `/build/tbm/gdal-1.3.1/frmts/fit'
> make[2]: *** [fit-install-obj] Error 2

--- ./frmts/fit/fitdataset.cpp~ 2006-03-16 03:14:38.000000000 +0000
+++ ./frmts/fit/fitdataset.cpp  2006-03-16 03:14:48.000000000 +0000
@@ -174,7 +174,7 @@
-    FITRasterBand::FITRasterBand( FITDataset *, int );
+    FITRasterBand( FITDataset *, int );
     // should override RasterIO eventually.

Martin Michlmayr

--- End Message ---
--- Begin Message ---
Source: gdal
Source-Version: 1.3.1-5

We believe that the bug you reported is fixed in the latest version of
gdal, which is due to be installed in the Debian FTP archive:

  to pool/main/g/gdal/gdal-bin_1.3.1-5_i386.deb
  to pool/main/g/gdal/gdal_1.3.1-5.diff.gz
  to pool/main/g/gdal/gdal_1.3.1-5.dsc
  to pool/main/g/gdal/libgdal-doc_1.3.1-5_all.deb
  to pool/main/g/gdal/libgdal1-1.3.1-dev_1.3.1-5_i386.deb
  to pool/main/g/gdal/libgdal1-1.3.1_1.3.1-5_i386.deb
  to pool/main/g/gdal/python-gdal_1.3.1-5_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [EMAIL PROTECTED],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Francesco Paolo Lovergine <[EMAIL PROTECTED]> (supplier of updated gdal package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [EMAIL PROTECTED])

Hash: SHA1

Format: 1.7
Date: Tue,  4 Apr 2006 00:14:56 +0200
Source: gdal
Binary: python-gdal libgdal1-1.3.1-dev libgdal-doc gdal-bin libgdal1-1.3.1
Architecture: source i386 all
Version: 1.3.1-5
Distribution: unstable
Urgency: low
Maintainer: Debian GIS Project <>
Changed-By: Francesco Paolo Lovergine <[EMAIL PROTECTED]>
 gdal-bin   - Geospatial Data Abstraction Library - Utility programs
 libgdal-doc - Documentation for the Geospatial Data Abstraction Library
 libgdal1-1.3.1 - Geospatial Data Abstraction Library
 libgdal1-1.3.1-dev - Geospatial Data Abstraction Library - Development files
 python-gdal - Python bindings to the Geospatial Data Abstraction Library
Closes: 357189 360389
 gdal (1.3.1-5) unstable; urgency=low
   [ Paul Wise ]
   * Fix GCC 4.1 FTBFS with patch from Martin Michlmayr. Closes: #357189
   [ Francesco Paolo Lovergine ]
   * Fix Unix ODBC FTBS with patch by me. Closes: #360389
   * Added versioned build-dep on unixodbc-dev for safety, just in case.
 758b7e7b31011c71c16517a63ba1b2d6 1097 science extra gdal_1.3.1-5.dsc
 4844674542584fe61024ddb06e944a13 8178 science extra gdal_1.3.1-5.diff.gz
 476747c719a8ca31d5c29db3e1bcb70e 1760296 libs extra 
 eb3f913f5ee63b6152d3d6610a577d27 2115196 libdevel extra 
 1f4eb74c3aad208dc46adcf50647517e 72274 science extra gdal-bin_1.3.1-5_i386.deb
 6f4d02296cf539756eab655c7c009525 176830 python extra 
 5eee750f260290412402653db0cb632e 1035538 doc extra libgdal-doc_1.3.1-5_all.deb

Version: GnuPG v1.4.3 (GNU/Linux)


--- End Message ---
Pkg-grass-devel mailing list

Reply via email to