On Tue, 2006-04-11 at 15:09 +0200, Bill Allombert wrote:
> Package: grass
> Version: 6.0.2-2
> Severity: important
> Hello Debian GIS maintainers,
> There is a circular dependency between grass and libgrass:
> grass          :Depends: libgrass (= 6.0.2-2)
> libgrass :Depends: grass (= 6.0.2-2)

These really depend on each other since each is unusable without the
other. So it looks like we need to find the stuff in the grass package
that is used by the grass libs and move it to libgrass. Probably a
number of things in /usr/lib/grass/etc at least.


> Circular dependencies involving shared libraries are known to cause problems
> during upgrade between stable releases, so we should try to get rid of them.
> See threads 
> http://lists.debian.org/debian-devel/2005/06/msg02111.html
> http://lists.debian.org/debian-devel/2005/11/msg01101.html
> Cheers,

Pkg-grass-devel mailing list

Reply via email to